Resolved Internal Audio Device disappeared after 10.14.5 upgrade

Discussion in 'MacBook Pro' started by lexophob, May 22, 2019.

  1. lexophob macrumors newbie

    lexophob

    Joined:
    Nov 8, 2016
    Location:
    Switzerland
    #1
    Hi

    after the 10.14.5 upgrade my internal sound device disappeared from my MacBookPro15,1.
    In settings there is no internal sound device and in system information there is an empty page.
    All programs who want to play audio are crashing.

    Any hints? Anyone having the same issue?

    I did reset NVRAM (2x) -> no success
    I did a hardware diagnosis -> no issues

    Thanks
     
  2. Audit13 macrumors 601

    Audit13

    Joined:
    Apr 19, 2017
    Location:
    Toronto, Ontario, Canada
    #2
    Is it possible to roll back to an earlier OS?

    Have you run the internal diagnostics by holding down the "D" key after pressing the power button?
     
  3. lexophob thread starter macrumors newbie

    lexophob

    Joined:
    Nov 8, 2016
    Location:
    Switzerland
    #3
    Thanks for the reply.

    I have a backup from 1st of April - so yes it would be possible to roll-back .. but I would prefer not to :-/

    Yes I did run the diagnostics by holding down "D" with no errors - and I had sound just before the update.
     
  4. Audit13 macrumors 601

    Audit13

    Joined:
    Apr 19, 2017
    Location:
    Toronto, Ontario, Canada
    #4
    It could just be coincidence that the sound stopped working with the os update.

    You could create a new back up, perform a clean install by erasing the disk first to see if the sound returns.
     
  5. lexophob, May 22, 2019
    Last edited: May 22, 2019

    lexophob thread starter macrumors newbie

    lexophob

    Joined:
    Nov 8, 2016
    Location:
    Switzerland
    #5
    good hint with the clean install - i'll probably give it a shot.

    btw. external audio devices like bluetooth speakers or usb-speakers work fine.
    beep of plugged power works fine too.
    .. my guesstimate is that there is some driver issue with the internal audio :-(
    I've noticed that the Touch Bar takes about 1 Minute to display anything after the OS is already started.

    18F203 did not fix it either ..
     
  6. lexophob thread starter macrumors newbie

    lexophob

    Joined:
    Nov 8, 2016
    Location:
    Switzerland
    #6
    re-installation of the OS fixed the issue finally.
     

Share This Page

5 May 22, 2019