internal drive failed, new drive won't mount

Discussion in 'MacBook Pro' started by shoeshine, Apr 15, 2014.

  1. shoeshine macrumors member

    Joined:
    Feb 27, 2010
    #1
    Hey, trying to trouble shoot a Macbook Pro startup problem:

    mid-2010 15" MBP
    couple of days ago booted up and had grey screen with question mark folder.
    tried resetting MSC and NVRAM, to no avail.
    further reboots had a apple logo crossed out or just grey screen and nothing.
    no chimes.

    -Pulled the drive, which was a stock seagate, placed in external case and came up as not recognized.
    -booted MBP from external firewire drive with an OS partition on it, worked fine.
    -assumed this meant a good ole drive failure, bought a new SSD, popped in the MBP and while booted from an external, tried formatting drive, and it wouldn't format.
    -took SSD back out, formatted and installed OSX while it was in an external case, booted while connected to external case.
    -put SSD back in MBP, get nothing but a grey screen.

    given that the original HDD wouldn't mount in an external case i assumed that just meant a bad drive, but clearly something else is up? Bad SATA cable? it seems curious that the original HDD is no longer readable AND now the new one won't boot? is this a logic board issue?

    I booted the MBP with the new SSD in it to target disk mode and in disk utility you can see the drive icon, but the drive itself won't mount.

    any thoughts?
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    It is fairly common for the drive cable to fail on these. Logic board failure would also douse this, but that is much less common.
     

Share This Page