Internal Mac speakers making a sharp popping noise?

Discussion in 'Mac Basics and Help' started by Mew2468, Jan 9, 2010.

  1. Mew2468 macrumors regular

    Joined:
    Apr 11, 2009
    Location:
    Home of the 2010 Winter Games
    #1
    Occasionally I'll be listening to music or just changing the volume and a sharp popping sound will occur from the internal speakers and then they shut off. No sound can play it all. To fix the problem I just have to reboot and then the speakers work fine. Does anybody know why this happens?

    This happens on my iMac sometimes and it just happened on my new MacBook Pro and I'm wondering if it's damaging the speakers in any way.

    Edit: I don't remember what I was doing on my iMac to cause this, but I do know what caused it on my MacBook Pro. I was recording my canary singing (don't ask why) using Quicktime Pro, and then listened to it (it worked fine). I imported it into GarageBand to crop it and when I previewed it there to figure out where to crop the file, my speakers popped and GarageBand gave me a warning about the current track not being optimized or something. Note that never happened on my iMac.
     
  2. charlieku macrumors newbie

    Joined:
    Jan 11, 2010
    #2
    Sharp popping

    My Mac OS X just started popping today. It first happened when Mail went to get new emails. At the conclusion of downloading new mail, there were two popping noises, quite loud. Since it first happened earlier today, I have heard the sound while working in other applications, but when in Mail, I can produce the two pops every time I "Get mail". Sure would like to know what is causing it before something serious develops. Thanks, Charlie
     
  3. razorboy1969 macrumors newbie

    razorboy1969

    Joined:
    Nov 21, 2009
    #3
    Hi there. No sharp popping sound for me, although there is occasional static coming from the speakers, esp when my mbp has been on for extended periods. Still trying to figure out the root cause. I hope the speakers are not shot. My mbp is still pretty new (about 2 months old).
     
  4. greyham28 macrumors newbie

    Joined:
    Mar 21, 2011
    #4
    Same thing happened to me while watching a YouTube video. I can get sound when I plug headphones in and over airtunes via my airport extreme, but I can't get my internal speakers to play anything but a terribly disconcerting and annyoing hard or sharp clicking, popping sound.

    It makes the noise whenever I do anything that would require a sound to be made but it only does it once and then seems to shut off the speakers. For example, if I click a youtube link, the video starts and there is one loud click (even if my volume is turned way down low, as long as it's not on mute it will make the noise) and then no sound. But if I click pause and then play again, it will make the clicking noise; it also happens if I scroll through the video.

    This happened to me a few weeks ago and eventually they started to play sounds on what I think must have been just certain frequencies -- I could make out words but I didn't enjoy listening to sound. It was very high-pitched and abnormal.

    I finally gave up and took it to the apple store. The technician just popped it open and the sound was working fine. He thought I was crazy. Now it's back...

    I thought Macs were just supposed to work?

    I'm on a 13 in. MacbookPro that I bought in July 2010.
     
  5. youngcricket macrumors newbie

    Joined:
    May 8, 2011
    Location:
    Pennsylvania USA
    #5
    internal mac speaker

    my :apple: macbook pro does that every few days and anytime it happens all i have to do is restart and its fine. Hope that helps.
     

Share This Page