International Imessege question

Discussion in 'iOS 5 and earlier' started by Globug, Mar 23, 2012.

  1. Globug macrumors 6502

    Globug

    Joined:
    Mar 16, 2012
    Location:
    Brisbane Australia
    #1
    I tried to send an Imessege to a friend of mine in Russia, and as far as i know he's running Ios5 on an iPhone 4 or 4s. For some reason when i sent it to his phone number it sent as a regular text even though i have "send as text" disabled... and when he sent me a messenge back via email it sent just fine on imessege.

    Anyone know wtf is happening? Thanks!
     
  2. stephenkurtzke1 macrumors newbie

    Joined:
    Jul 7, 2011
    #2
    Have you tried sending it to his email address and making sure your Caller ID is set to your email address?
    Basically, try to eliminate the phone number all together, I think.
    Just something to try, not sure if it'll work though.
     
  3. Globug thread starter macrumors 6502

    Globug

    Joined:
    Mar 16, 2012
    Location:
    Brisbane Australia
    #3
    its set to my number and i want it that way, unless there are downfalls to having to linked to the number? If so can explain benefits of having it linked to email?

    I DO receive imessages from him but as far as i know it goes: his ID---->myphonenumber and myphonenumber----> his ID. all via imessage. its all blue.
    When i tried to send it to his number it sent as a text and not imessege, even though "send as message" is disabled. :confused:
     
  4. Arelunde macrumors 6502a

    Arelunde

    Joined:
    Jul 6, 2011
    Location:
    CA Central Coast
    #4
    It's my understanding that the best way to have your iMessage iPhone settings is the phone number as primary BUT also add your email address as a secondary contact. That way, you get iMessages via whatever is available between you and the other person.
     
  5. NJFP macrumors 6502

    Joined:
    Feb 18, 2009
    #5
    Friend of mine and I had same problem. HE had his primary receiving as his email, that's why it always went green on my end, but came back blue on his reply. Have your friend check his settings.
     

Share This Page