International SMS / International Assist Problem with Unlocked iPhone

Discussion in 'iPhone Tips, Help and Troubleshooting' started by aarontcp, Jun 2, 2010.

  1. aarontcp macrumors newbie

    Joined:
    Jun 2, 2010
    #1
    So I just spent about 2 hours googling around for a solution to this and found none.

    I have an AT&T iPhone 3G, 3.12 firmware, jailbroken & unlocked with blackra1n / blacksn0w.

    I've been taking it with me from country to country, and local calls and texts work fine - it's the international ones that have problems.

    I have all my numbers stored in the +1 XXX XXX XXXX or +44 XXXX XXXXXX format...

    The problem is, when I try to text, the iPhone is taking the "+" symbol (plus symbol) and turning it into 011, which is the US IDD code for dialing overseas. I've tried putting in 001, 002, 021 (all IDD codes here in Singapore) but the iPhone reverts them to 011.

    Things I've tried:
    * Deleting numbers from address book & entering them in manually.
    * Any/all variations of international dialing codes, from "+" symbols to 011 to 001 to 002 etc etc
    * Putting my AT&T SIM in, turning off international assist then putting the local SIM card in.

    I think what's happening is that because it's a US/AT&T phone, somewhere it's configured to automatically prefix international numbers with 011 format. But googling around, I can't find anyone else with this problem or a solution for it.

    - Aaron
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    settings/phone
    Turn off international assist.
    International assist automatically adds the correct prefix to US numbers when dialing from abroad.
    See if this does it.
     
  3. aarontcp thread starter macrumors newbie

    Joined:
    Jun 2, 2010
    #3
    International Assist doesn't appear when I don't have a AT&T SIM card in there.

    But I did put mine in, made sure International Assist was turned off, then put a local SIM card back in. Same problem still :(
     
  4. bTaryag macrumors member

    Joined:
    Sep 8, 2009
    #4
    This is an old thread but I'm glad someone else has this issue!

    I have this problem with one of my contacts. It treats the +country code as 011, and even if I just use the local number (when overseas) with the +country code, it still puts a 011 in front. So, I cannot text this person because it always adds 011, and overseas 011 is a wrong number.

    I have this problem only with one contact - a foreign contact I used to text while I was in the USA. It seems that the iPhone got stuck treating that phone number as having a 011 prefix. Even after I deleted the contact, turned off dial assist, reset the phone, when I enter that number manually and text it, the iPhone sends it to 011....

    Other contacts that I haven't texted to while in the USA work fine both in the + format or the local format.

    Weird!
     
  5. Peterdavid macrumors newbie

    Peterdavid

    Joined:
    Aug 19, 2016
    #5
    I have same problem. Did you ever found a solution?

     

Share This Page