Internet Account Google "Failed to Authenticate"

donawalt

macrumors 6502
Original poster
Sep 10, 2015
460
198
I changed my Google password today, and everything works fine to re-login (iPhone, iPad, browsers) except I cannot get the Internet Account Google to successfully log in on my Mac - System Preferences/Internet Accounts. As a result, I cannot use the Calendar, Contacts, or Mail apps now!

I have tried:
1. Initially, I had the google authentication (sends a message to your iPhone) - password worked, iPhone says authenticated, Mac says "Authentication failed try again later".
2. I changed authentication to 2 factor with text message. Entered the code in, got "Authentication failed try again later"
3. Turned off all 2FA - just entering password - got "Authentication failed try again later"
4. Purposely tried entering a bad password to be sure I was entering it correctly (it is a long password that I paste in) - it says "Incorrect password". I enter the right password and I get "Authentication failed try again later".
5. Deleted the Google account and tried re-adding it - I get "Authentication failed try again later".
6. Tried restarting the Mac - get "Authentication failed try again later".
7. Deleted all Google information in keychain - got "Authentication failed try again later"
8. Tried Googling an answer, found nothing new.

Does anyone have any ideas? I am in a panic lol - Macbook is a brick now for the work I do.

Thanks!
 
  • Like
Reactions: kylestenson

LPBrouwer

macrumors newbie
Oct 29, 2017
4
0
Netherlands
I have the exact same issue.
Just (clean) installed Mojave, but I can't connect to my Google account (or my Facebook account for that matter).
I did not change my password. I know the passwords, I can login through Safari, but not through the Internet accounts...???

I tried the option above, to enable 'less secure apps' in Google: doesn't work.
I have removed all stored keys for Google in my Key-chain: no resolve.

Anybody have any other ideas?
(running a mid 2012 13" MacBook Air).

Thank you for any help.
 

Hikerdave

macrumors newbie
Feb 21, 2017
10
1
San Diego
I changed my Google password today, and everything works fine to re-login (iPhone, iPad, browsers) except I cannot get the Internet Account Google to successfully log in on my Mac - System Preferences/Internet Accounts. As a result, I cannot use the Calendar, Contacts, or Mail apps now!

I have tried:
1. Initially, I had the google authentication (sends a message to your iPhone) - password worked, iPhone says authenticated, Mac says "Authentication failed try again later".
2. I changed authentication to 2 factor with text message. Entered the code in, got "Authentication failed try again later"
3. Turned off all 2FA - just entering password - got "Authentication failed try again later"
4. Purposely tried entering a bad password to be sure I was entering it correctly (it is a long password that I paste in) - it says "Incorrect password". I enter the right password and I get "Authentication failed try again later".
5. Deleted the Google account and tried re-adding it - I get "Authentication failed try again later".
6. Tried restarting the Mac - get "Authentication failed try again later".
7. Deleted all Google information in keychain - got "Authentication failed try again later"
8. Tried Googling an answer, found nothing new.

Does anyone have any ideas? I am in a panic lol - Macbook is a brick now for the work I do.

Thanks!
I am having the same problem and I did verify that IMAP is turned on on gmail and I have allowed logging for less secure apps. I have been having a few different problems with Mac mail since upgrading to 10.14, so today I deleted my account thinking that maybe the problems would go away once I re-added my account, but I just keep getting "Authentication failed Failed to authenticate with Google, please try again later” error. I do not have 2-factor login setup.

BTW - I was able to get gmail working again by clicking on “Other account” choosing Mail account and then putting in the settings for gmail IMAP manually, but this does not allow access to the Google calendars this way and I have not found a way to add the Google Calendar to my Mac Calendar. The mail solution is a work around because I think the regular way is broken.
 
  • Like
Reactions: HalGumbert

zorinlynx

macrumors 603
May 31, 2007
6,050
8,549
Florida, USA
Count me in as also having this issue.

I decided to change my Google password for my work Google account, on recommendation from the Safari password manager because I had used that same password somewhere else. After changing it, I can still login to Google via Safari, but can't connect to the account on either my home Mac, work Mac or iPhone.

The fact that we're all having this problem today suggests this may be a problem on Google's end, though. Either that or a bug in Mojave and iOS 12.

Damnit. That'll teach me to try to be more secure!

EDIT: Hmm. A Twitter search finds another person with this problem within the last couple hours, but nobody really complaining about it in the last couple weeks.

So this may be a temporary issue on Google's end. We'll know soon enough I'm sure.
 
Last edited:

iOZZY

macrumors regular
Mar 17, 2013
114
31
Stamford, England
Was able to add my google mail account through the native app on my replacement SE on Saturday without problem but tonight I cleared up some of my logged in devices and accidentally removed the current iPad and iPhone SE authorisations. Now I can't sign into either, grrr. Accepts user name/password and 2 factor code then crashes back out to the mail set up screen. Hopefully just a temporary glitch.

All other apps sign in ok and my 6 Plus, which remained authorised, is working fine with the native mail app.
 

mrpaqman

macrumors newbie
Oct 8, 2018
2
1
I changed my Google password today, and everything works fine to re-login (iPhone, iPad, browsers) except I cannot get the Internet Account Google to successfully log in on my Mac - System Preferences/Internet Accounts. As a result, I cannot use the Calendar, Contacts, or Mail apps now!
Seeing the same issue here. It all derives from resetting the password.

Spent an hour with Google G Suite support, they blame Apple.

"I see that G Suite and GMail are working fine, we do not troubleshoot mail clients" - G Suite Support

+ I pointed out that it is a server issue.

"We don't handle server issues here, only G Suite services" - G Suite Support

Spent time with Apple, they blame Google.
"I am seeing that Google had not yet updated their systems to be on par with the new iOS and are asking customers to try again later" - Apple Support

I don't really care who broke it, just get it fixed Apple/Google. Changing a password should not break this so easily.

My stats:
> G Suite Account
> Strong password, 2FA
> iMac (High Sierra - MacOS 10.13.6) with Apple Mail (won't allow adding account, comes up with the error "Failed to authenticate with Google, please try again later.")
> iPhone X (iOS 12.1) with iOS Mail (won't allow adding account, goes through the process, 2FA, then goes back to "Add Account" screen)

Was able to replicate this on several other computers (Macbook Pro, iMac 2017) as well as other iPhones (7 & 8). So it is not a network issue, not an account issue, not a device issue. Something is broken, clearly.
 
  • Like
Reactions: zorinlynx

zorinlynx

macrumors 603
May 31, 2007
6,050
8,549
Florida, USA
Spent time with Apple, they blame Google.
"I am seeing that Google had not yet updated their systems to be on par with the new iOS and are asking customers to try again later" - Apple Support
I suspected that at first but the fact that High Sierra is having the problem too suggests it's definitely on Google's end.

It's just a matter of how long it will take for the fact that "something is ****ed" to trickle to the appropriate teams at Google to get it fixed. Hopefully not too long; I like having my work calendar on my iPhone.
 

m_matthew

macrumors newbie
Nov 2, 2017
1
2
Monterey, CA
I set up an app password within my Google account. https//myaccount.google.com/security, then “App passwords” under “Password & sign-in method”. I had to set up my Google account as “other” in the System Preferences>Internet Accounts, but once there I was good to go.

I changed my Google password today, and everything works fine to re-login (iPhone, iPad, browsers) except I cannot get the Internet Account Google to successfully log in on my Mac - System Preferences/Internet Accounts. As a result, I cannot use the Calendar, Contacts, or Mail apps now!

I have tried:
1. Initially, I had the google authentication (sends a message to your iPhone) - password worked, iPhone says authenticated, Mac says "Authentication failed try again later".
2. I changed authentication to 2 factor with text message. Entered the code in, got "Authentication failed try again later"
3. Turned off all 2FA - just entering password - got "Authentication failed try again later"
4. Purposely tried entering a bad password to be sure I was entering it correctly (it is a long password that I paste in) - it says "Incorrect password". I enter the right password and I get "Authentication failed try again later".
5. Deleted the Google account and tried re-adding it - I get "Authentication failed try again later".
6. Tried restarting the Mac - get "Authentication failed try again later".
7. Deleted all Google information in keychain - got "Authentication failed try again later"
8. Tried Googling an answer, found nothing new.

Does anyone have any ideas? I am in a panic lol - Macbook is a brick now for the work I do.

Thanks!
 

mrpaqman

macrumors newbie
Oct 8, 2018
2
1
I set up an app password within my Google account. https//myaccount.google.com/security, then “App passwords” under “Password & sign-in method”. I had to set up my Google account as “other” in the System Preferences>Internet Accounts, but once there I was good to go.
This is a solid workaround, good call m_matthew.

Here's a quick way to get it done:

https://support.google.com/accounts/troubleshooter/3178296
 

chrfr

macrumors G3
Jul 11, 2009
9,580
3,478
I’m having the same problem. I have 2-factor enabled so I can’t use the “less secure apps” option, but app-specific passwords are working at this point.
I changed my password last night and entered the new passwords on 2 iOS devices yesterday and 2 today, and they’re working without a problem, but the Macs I tried changing today all have the error.
Edit: I have no idea if it has anything to do with me having made an app-specific password, but the normal means of adding the Google account through Internet Accounts in System Prefs is now working.
 
Last edited:

donawalt

macrumors 6502
Original poster
Sep 10, 2015
460
198
One other interesting side note to this - after all was done and the Mac was logged in to Google, I went back to the Google privacy site and turned off the allowing of access for less secure apps. I then turned 2 step verification back on, made sure that was working correctly on all devices. A little later, my Mac asked me to enter my password for Google in System Preferences - uh oh I thought. I may have to turn on 'allow access to less secure apps' again. But no! It took the password with no problems! Feels like a bug somewhere in this, but it's set up fine now. Don't touch it!!! lol.
 

chrfr

macrumors G3
Jul 11, 2009
9,580
3,478
One other interesting side note to this - after all was done and the Mac was logged in to Google, I went back to the Google privacy site and turned off the allowing of access for less secure apps. I then turned 2 step verification back on, made sure that was working correctly on all devices. A little later, my Mac asked me to enter my password for Google in System Preferences - uh oh I thought. I may have to turn on 'allow access to less secure apps' again. But no! It took the password with no problems! Feels like a bug somewhere in this, but it's set up fine now. Don't touch it!!! lol.
I suspect some behind the scenes changes were happening with Google and Apple yesterday due to the security changes Google was putting in place. Everything seems to be working this morning.
 
  • Like
Reactions: donawalt

DiegoCaceres

macrumors newbie
Nov 23, 2018
3
0
If you are using G-suite accounts you might wanna check all this things:

1) Check that the API's are enabled: Admin Console > Security > API permissions
2) Check that IMAP is enabled https://support.google.com/mail/answer/7126229?hl=en
3) Disable Sign-in cookies or revoke access of mac OS https://support.google.com/accounts/answer/3466521?hl=en (check at the bottom for the tittle Remove site or app access).

Keep in mind you don't really need less secure apps when you add the account on a maccomputer when you select "add a Google Account", this is an OAUTH type of authentication, you don't really need less secure apps when you add the account like that. You need less secure apps when you add this as "Other" because you are authenticating the user directly from the tool.

I hope this works.
 

donawalt

macrumors 6502
Original poster
Sep 10, 2015
460
198
If you are using G-suite accounts you might wanna check all this things:

1) Check that the API's are enabled: Admin Console > Security > API permissions
2) Check that IMAP is enabled https://support.google.com/mail/answer/7126229?hl=en
3) Disable Sign-in cookies or revoke access of mac OS https://support.google.com/accounts/answer/3466521?hl=en (check at the bottom for the tittle Remove site or app access).

Keep in mind you don't really need less secure apps when you add the account on a maccomputer when you select "add a Google Account", this is an OAUTH type of authentication, you don't really need less secure apps when you add the account like that. You need less secure apps when you add this as "Other" because you are authenticating the user directly from the tool.

I hope this works.
At least for non G-Suite accounts like mine, this is not really true - I added as a Google account not other, and it would not authenticate.
 

DiegoCaceres

macrumors newbie
Nov 23, 2018
3
0
At least for non G-Suite accounts like mine, this is not really true - I added as a Google account not other, and it would not authenticate.
I understand, things that I would try for your scenario:

1) Try a different Mac.
2) Different connection.
3) Check what version of Mac you have and if you are able to upgrade that or change the Mac version.
4) Create a new free gmail account and try that one.

I tested my free gmail account on my Mac and it worked properly, If you want try to retrieve the logs by the time you replicate this and send it to me. (to locate the logs, locate the console on the finder and then copy and paste the errors and paste it on a notepad, Maybe I can see more from there, also replicate the issue once you located the logs try to clear the log so that I am able to locate the error easier)
 

zorinlynx

macrumors 603
May 31, 2007
6,050
8,549
Florida, USA
If you are using G-suite accounts you might wanna check all this things:

1) Check that the API's are enabled: Admin Console > Security > API permissions
2) Check that IMAP is enabled https://support.google.com/mail/answer/7126229?hl=en
3) Disable Sign-in cookies or revoke access of mac OS https://support.google.com/accounts/answer/3466521?hl=en (check at the bottom for the tittle Remove site or app access).

Keep in mind you don't really need less secure apps when you add the account on a maccomputer when you select "add a Google Account", this is an OAUTH type of authentication, you don't really need less secure apps when you add the account like that. You need less secure apps when you add this as "Other" because you are authenticating the user directly from the tool.

I hope this works.
This is a fairly old thread; has this problem come back?

I'm still signed into all my Google stuff, but don't dare sign out and back in...
 

telequest

macrumors regular
Feb 1, 2010
183
42
NJ
Suddenly this problem is affecting me ... I keep getting authentication requests in Apple Mail for my gmail accounts, and then get "authentication failed" much of the time. Until the last few days, never got these requests at all. Not aware that I've changed anything on my end. Did Google change things in the last week or so?

This is on my MBP 2018 running Mojave 10.14.4 and Mail 12.4
 

Dwalls90

macrumors 601
Feb 5, 2009
4,811
1,267
Suddenly this problem is affecting me ... I keep getting authentication requests in Apple Mail for my gmail accounts, and then get "authentication failed" much of the time. Until the last few days, never got these requests at all. Not aware that I've changed anything on my end. Did Google change things in the last week or so?

This is on my MBP 2018 running Mojave 10.14.4 and Mail 12.4
I'm in the same boat. This has been non-stop since 10.14.4.
 

Blu Boy

macrumors newbie
Jul 22, 2019
1
0
I changed my Google password today, and everything works fine to re-login (iPhone, iPad, browsers) except I cannot get the Internet Account Google to successfully log in on my Mac - System Preferences/Internet Accounts. As a result, I cannot use the Calendar, Contacts, or Mail apps now!

I have tried:
1. Initially, I had the google authentication (sends a message to your iPhone) - password worked, iPhone says authenticated, Mac says "Authentication failed try again later".
2. I changed authentication to 2 factor with text message. Entered the code in, got "Authentication failed try again later"
3. Turned off all 2FA - just entering password - got "Authentication failed try again later"
4. Purposely tried entering a bad password to be sure I was entering it correctly (it is a long password that I paste in) - it says "Incorrect password". I enter the right password and I get "Authentication failed try again later".
5. Deleted the Google account and tried re-adding it - I get "Authentication failed try again later".
6. Tried restarting the Mac - get "Authentication failed try again later".
7. Deleted all Google information in keychain - got "Authentication failed try again later"
8. Tried Googling an answer, found nothing new.

Does anyone have any ideas? I am in a panic lol - Macbook is a brick now for the work I do.

Thanks!
[doublepost=1563836445][/doublepost]When you add account, do it under "Other" (not google). Problem solved.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.