Internet Browser/DNS issues

Discussion in 'Mac Basics and Help' started by IanHarold, Jan 22, 2010.

  1. IanHarold macrumors newbie

    Joined:
    Sep 7, 2008
    #1
    I seem to be having somewhat of a problem with my internet. It connects and works just fine for programs such as mail and iChat, but when I open my browser, it doesn't open the web pages and usually comes back with a "server not found" page. If I go into my network settings and hit Renew DHCP, it tends to work itself out. I think it might have something to do with a DNS problem but I honestly have no idea. This only happens at my girlfriends house on her Belkin router, and back home on my netgear I dont have any issues at all. Does anyone have any idea how I might be able to fix this?

    Added: most of the time my homepage will load (wikipedia) but then none other will work.

    thanks for any help
     
  2. Queso macrumors G4

    Joined:
    Mar 4, 2006
    #2
    Do the routers in your and your girlfriend's houses use the same IP ranges, subnet masks and gateway addresses? If so change one of them.

    For instance, if your router currently uses

    Network 192.168.1.0
    Mask 255.255.255.0
    Gateway (&DNS) 192.168.1.254

    Change it to use

    Network 192.168.2.0
    Mask 255.255.255.0
    Gateway (&DNS) 192.168.2.254 <- this will need to be the router IP address

    If you have to change separate DHCP settings to match the above then type those in too. You have to ensure that you enter all the necessary changes into the router before you commit them, otherwise you'll end up with a big mismatch and not be able to get on at all.

    What type of router is it? It'll give us a clue as to how you need to apply the steps.
     

Share This Page