Internet Connection difficulty with both Ethernet cable and AirPort

Discussion in 'Mac Basics and Help' started by Doomded, Mar 24, 2009.

  1. Doomded macrumors newbie

    Joined:
    Mar 26, 2007
    #1
    I connect to the internet mainly through an ethernet cable, connected to my own base for ethernet connections (Might be a router, but doesn't connect directly to the internet) which is connected to the main Linksys router on the other side of my house, which even has a wireless connection.

    Regardless, this setup has worked without issue for a long time now, but all of a sudden now, I cannot connect to the internet (On my Mac).

    I have tried unplugging the routers, for extended periods of time, plugging them back in, but I cannot connect to the internet. Whats awkward, is that when I check the Network settings in the System Preferences, it says clearly is that the Ethernet Cable is connected (Which it is), and as a backup, I have even connected to my Wireless Network through AirPort (Which says it is connected), but I cannot connect to the internet through Firefox, or any instant messaging service.

    On the main computer, with the main router, the internet works fine. When I try to load Firefox on my Mac, it sometimes takes a long time loading (On a blank screen), and never loads usually (With occasional loads, but usually does not connect).

    Does anyone think they have any helpful suggestions or ways to fix this problem? Am I being specific enough?

    Thanks.
     
  2. dvdhsu macrumors 6502a

    dvdhsu

    Joined:
    Mar 28, 2008
    Location:
    Palo Alto, CA
    #2
    You could try switching the Mac over to where the main computer is, and plug the ethernet cable in there and see if that works.
    If that doesn't work, you know it's the Mac.
    If that works, you know it's the 2nd router or Airport problems.
     

Share This Page