Internet Connection Down, Weird Keyboard Problem

Discussion in 'MacBook Pro' started by CeCe, Jan 28, 2007.

  1. CeCe macrumors member

    Nov 5, 2006
    I'm using a C2D Macbook, I installed the Airport Extreme Update 2007-001 and after restarting my computer, I was unable to connect to the internet wirelessly.

    Things I've tried, but didn't work:

    - restarting the computer
    - disk utility
    - manually entering my WEP password

    But now I realize that if I type '$' in the password area, I'm unable to type any key to the let of T (on the first row), F (on the second row), and V (on the last row). However, I'm able to use those keys if I don't type '$' first. But my WEP password requires me to use the keys I'm unable to type....this is frustrating.

    I wish I didn't install the software updates....or undo them, but I don't think this is possible.

    Anyone know how fix this problem? I have a 2Wire modem and internet works fine if I connect it using the wire, it just doesn't work wirelessly.

  2. Yukinara macrumors member

    Jan 26, 2007
    hey,that happen to my laptop too,mine is a C2D and I'm using 2Wire modem,after I update to 2007-001,I can't use wireless anymore,but everything is ok if I use a cable,but.......I can't use cable for long

    What happen with the new update??????

    gotta call Apple tomorrow
  3. CeCe thread starter macrumors member

    Nov 5, 2006
    I called them today and spent almost 2 hours with them, nothing has changed. I'm thinking about an archive and reinstall of OS X, however the technician said to wait a bit before I do that in case they have a new update. I have a 2Wire modem too. It's a hassle to have to connect using the ethernet cable.

    Here's a list of things we tried:
    - resetting the PRAM
    - deleting the password in the keychain (both login and system)
    - creating a test account
    - changing the security from WEP-open to WPA
    - typing the password differently (ex: with and without the '$' in front)
  4. aussie.damo macrumors regular

    Nov 20, 2006
    Hi, I have a d-link wireless modem. I'm also having this problem. I have disabled all security and it is working again. WEP or WPA stop it from working.

    Hope they fix this VERY soon, i'm uncomfortable operating with no WLAN security.

  5. MACDRIVE macrumors 68000


    Feb 17, 2006
    Clovis, California
    That means them dudes driving around your neighborhood in a plain white van can intercept your data wirelessly and run up your credit card.
  6. Yukinara macrumors member

    Jan 26, 2007
    well,I called them and they said that they were awared of the situation and tried to investigate right now.Everything will be ok soon
  7. CeCe thread starter macrumors member

    Nov 5, 2006
    I managed to get it fixed without having to do a archive reinstall (which I was dreading, mostly because it seems intimidating).

    I just switched over from WEP-open to WPA. I tried doing that before, but when I was filling in the password, I guess it was filled out before and if I pressed the down arrow and press enter it would fill the password in for me. But when that happened it would refresh the page and keep it as WEP-open and I guess the password without a "$" wouldn't work using WEP-open, but ok in WPA.
  8. Yukinara macrumors member

    Jan 26, 2007
    so everything is ok again?Can you tell me more details about this?I check my security again and it's WEP. Actually,the modem is not mine,but I will tell the owner to change it. At the previous post, you tried to change from WEP to WPA,but it didn't work,now it work??
  9. Joe-Data macrumors newbie

    Feb 3, 2007
    Change to WEP Shared

    Hi guys, try this:

    Open the Network control panel and delete the trusted network with the problem.

    In the 2Wire Wireless settings change the method of authentication to WEP-Shared or WEP-Compartido (in spanish).

    Save the settings and ad a new trusted network in Network Control Panel or connect by your old way.

    Xtra tip: With this change some PC's with XP can´t connect to 2Wire modems

    ___ JOE
  10. CeCe thread starter macrumors member

    Nov 5, 2006
    It didn't work before due to a keyboard thing...but it's ok now. If you're not the owner (ex: if you're renting, etc) it's going to be harder because you can't just make the change yourself unless you have the account name and password. It will affect all the computers that use the network, not just yours...I don't know if that makes any sense.

    Just another note, I can connect wirelessly to the 2Wire modem, however it disconnects randomly and Airport has problems automatically reconnecting to the internet when I wake my Macbook up from sleep.

Share This Page