Internet Connection Dropping with Yosemite

Discussion in 'OS X Yosemite (10.10)' started by urbanmojo, Dec 17, 2014.

  1. urbanmojo macrumors member

    Joined:
    Jun 16, 2009
    #1
    Hi:

    I have problems connecting in Yosemite over wifi. Here are the facts:

    1. Pinging router always comes back fine and quickly through repeated pings.
    2. Pinging outside source like google.com sometimes drops for sometimes minutes at a time.
    3. iPad and windows 8 computer on the network work fine.
    4. The Macbook hasn't had this problem on other networks.
    5. MTU was at 1300 (fix for VPN issue), moved it up to 1453. Think that helped a bit as return trips to google.com are a bit faster.
    6. Pinging outside IP address also drops, so most likely not name resolution problem. (like google.com IP address 173.194.126.161.
    7. Tried removing network preference and config files and rebooting.
    8. Tried different DNS servers (but as I say doesn't look like name resolution).
    9. Not currently physically able to test a wired connection (no adapter for new macbook pro).

    Anything else I can check here?
     
  2. urbanmojo thread starter macrumors member

    Joined:
    Jun 16, 2009
    #2
    More information:

    The network is 802.11n 2.4 GHz.
     
  3. sojer2005, Dec 18, 2014
    Last edited: Dec 18, 2014

    sojer2005 macrumors member

    sojer2005

    Joined:
    Nov 29, 2007
    Location:
    Poland
    #3
    Hi,
    I am having similar issues with Yosemite and Mac mini 2014 - experiencing random slow downs on 2.4GHz or 5GHz. I have dual band Asus router N66U - its a stable router, so it is not the issue here.
    The connection starts to slow down few minutes after the boot up.
    For me the solution is: disabling wifi (the menu bar) and re-enabling wifi makes the WAN connection stable.

    Other solutions (removing network preferences, etc.) did not worked for me. I have no clue whats is going on.
     
  4. jozeppy26 macrumors 6502

    jozeppy26

    Joined:
    Jul 8, 2008
    Location:
    St. Louis
    #4
    It was my understanding that Yosemite has been having Wifi connectivity and reliability issues in general, but especially with Asus routers. I would check the super huge thread in this forum regarding the issue. I know it's something Apple has been actively and aggressively trying to fix in the latest Yosemite 10.10.2 developer previews.
     

Share This Page