Internet Connection Issue

Discussion in 'macOS' started by phl33t, Feb 4, 2009.

  1. phl33t macrumors newbie

    Joined:
    Feb 4, 2009
    #1
    Hi,
    I have recently been having a problem with my MacBook Pro (2.4 ghz early 2008 model). When I go to certain websites, I get the error: "You are not connected to the Internet". This only happens on certain sites though. Eg http://google.ca works but http://google.com does not. I have no idea why though, because it does not do it every time (sometimes it works and sometimes it doesn't). Also, certain sites do not show all images and/or formatting, instead just the blue question mark. I have tried both Safari and Firefox with similar effects. Oddly, when I run Network Diagnostics it works for a few minutes, then stops again.

    I have recently set up a web/ssh server on another computer, and I have changed the port forwarding on my router. I have forwarded port 80 TCP (and 22 TCP), but I don't think that it's the problem as I disabled port forwarding temporarily only to have the same problem occur. Also, I read somewhere else that going to http://74.125.45.100/ and having Google open (which it did for me) means that there is a DNS problem. Is this true?

    Some pics:
    Google not working: http://i39.tinypic.com/2ro3j46.jpg
    Pictures/formatting missing: http://i39.tinypic.com/fdg29w.jpg
    (same for firefox and safari)

    I have tried all combinations of settings in the network prefs pane, but I still can't get it to work.

    Any ideas?
    Thanks
     
  2. Amdahl macrumors 65816

    Joined:
    Jul 28, 2004
    #2
    This could be a problem with your router. If it is a DNS problem, it might go away if you use OpenDNS servers instead:
    208.67.222.222
    208.67.220.220

    If it is not the DNS, check for firmware updates to your router, or see if you can connect without using the router.

    You can test which kind of problem it is by trying each of the following and see if one eliminates the problem.

    In Terminal:
    sudo ifconfig en1 mtu 1450 (usually, it is en0, but you seem to be using en1)

    In Firefox:
    browse to about:config
    set following:
    network.http.pipelining to true
    network.http.max-connections to 8
    network.http.max-connections-per-server to 3
     
  3. phl33t thread starter macrumors newbie

    Joined:
    Feb 4, 2009
    #3
    My computer was just stolen! Damn it. Oh well, i guess i dont need to worry about that problem now...
     
  4. ppc750fx macrumors 65816

    Joined:
    Aug 20, 2008
    #4
    It does indeed sound like a DNS issue, but don't use OpenDNS. There's nothing "open" about them, and they've been known to manipulate DNS records and return non-authoritative information.

    Instead, use the DNS servers:
    4.2.2.1
    4.2.2.2
    [...]
    4.2.2.6

    They're public resolvers, run by what used to be GTE, and have been returning authoritative information for many, many years.

    This might (might) help if your gateway is dropping connections. If you've got a WRT54G (or some other router which tends to choke when it's filled up its TCP connection table), this might alleviate the problem slightly, but it's not a fix.
     

Share This Page