Internet connection problems on my MacBook Pro

Discussion in 'MacBook Pro' started by JoarYeah, Aug 15, 2012.

  1. JoarYeah macrumors newbie

    Joined:
    Aug 15, 2012
    #1
    Hi everyone!

    I'm having the weirdest problem on my late 2011 MacBook Pro running Lion v. 10.7.4. When signing in to my account, the computer connects to the internet and says everything is fine; except it's not. It cannot connect to anything. When opening Chrome it states: Connection Refused.

    On the other hand, when my girlfriend signs in on her account everything works fine (I'm writing from this account now). If I then sign out from her account and sign in to mine: same problem. If I then sign out from my account and back to my girlfriends account it shows the same problem. If I restart the computer and begin by signing into her account, everything is once again fine.

    I thought this sounded like some sort of virus (I have downloaded a bunch of programs recently), but a virus search with ClamXav showed nothing.

    I'm getting really frustrated and hope that someone out there has had a similar problem and fixed it.

    Much appreciated,

    / Joar
     
  2. Interstella5555 macrumors 603

    Interstella5555

    Joined:
    Jun 30, 2008
    #2
    Was having a slightly similar problem for a few weeks, it would take ~30 seconds to connect to my wifi and even then it would take a long time to load pages with some "no connection" errors and overall speed slow. I finally just ran full maintenance with Onyx and seemed to have cleared up the problem. Also the fact that you GF can connect fine with her account on the same comp probably means something is just borked on your end.
     
  3. biskit96 macrumors newbie

    Joined:
    May 5, 2012
    #3
    Try fixing your router to a fixed channel. Sometimes that helps.
     
  4. davidhaynes macrumors newbie

    Joined:
    Jun 17, 2011
    Location:
    Seattle, WA
    #4
    Try using a new password on the router. Seemed like the only think that worked for me.

    David
     
  5. JoarYeah thread starter macrumors newbie

    Joined:
    Aug 15, 2012
    #5
    Thanks for all replys guys!

    It has started working again now. Don't think I did very much; was about to abandon the account and start on a new one when after a restart it started working again. Might have been that I closed some start-up program such as Peer Guardian.

    Anyways, thanks!
     

Share This Page