Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

jonj64

macrumors newbie
Original poster
Dec 14, 2018
2
0
Japan
Macbook Pro (15-inch, 2017) High Sierra 10.13.6, Verbatim USB adapter, Roku 3

Been trying for a while now to connect a Roku 3 to my ethernet adapter (Verbatim USB hub with 10/100/1000 Ethernet Adapter on a Macbook Pro) and route out to the Internet via my Wifi adapter. The Macbook Pro connects to the Hotel Wifi (no password/authentication) without issues. Can even run NordVPN also. I am trying this method as it appears that the hotel has blocked streaming devices. So essentially am trying to turn my Macbook Pro into a router.

I went into Sharing, Turned on Internet Sharing, "Share connection from Wifi" to computers using "USB 10/100/1000". In network settings for the USB 10/100/1000 adapter I set the configs to the following; manually assign ip, 192.168.2.1(en7)/255.255.255.0/192.168.11.10(en0=Macbook Pro's Wifi IP). I can get the Ethernet link to go green, however once the Roku (obtains the ip 192.168.2.3) connects to the Internet, the Macbook Pro's Wifi drops. I seem to be missing some ip forwarding and NAT of private IP issue but not sure where to do that. I am willing to do it via command line if necessary (provided some good directions).

Here is the pertinent info via ifconfig;

en7: flags=8963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500
options=4<VLAN_MTU>
ether 00:e0:4c:05:01:37
inet6 fe80::cbe:7449:c22d:d2a7%en7 prefixlen 64 secured scopeid 0x7
inet 192.168.2.1 netmask 0xffffff00 broadcast 192.168.2.255
nd6 options=201<PERFORMNUD,DAD>
media: autoselect (100baseTX <full-duplex>)
status: active

en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
ether 8c:85:90:cd:a7:a9
inet6 fe80::1c83:1184:9a21:df46%en0 prefixlen 64 secured scopeid 0xd
inet 192.168.11.10 netmask 0xffffff00 broadcast 192.168.11.255
nd6 options=201<PERFORMNUD,DAD>
media: autoselect
status: active

bridge100: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
options=3<RXCSUM,TXCSUM>
ether 02:e0:4c:50:27:64
inet 192.168.3.1 netmask 0xffffff00 broadcast 192.168.3.255
inet6 fe80::e0:4cff:fe50:2764%bridge100 prefixlen 64 scopeid 0x13
Configuration:id 0:0:0:0:0:0 priority 0 hellotime 0 fwddelay 0
maxage 0 holdcnt 0 proto stp maxaddr 100 timeout 1200
root id 0:0:0:0:0:0 priority 0 ifcost 0 port 0
ipfilter disabled flags 0x2
member: en7 flags=3<LEARNING,DISCOVER>
ifmaxaddr 0 port 7 priority 0 path cost 0
nd6 options=201<PERFORMNUD,DAD>
media: autoselect
status: active


Any help would be greatly appreciated.
 

Attachments

  • Eth Adapter settings.png
    Eth Adapter settings.png
    182.9 KB · Views: 283

techwarrior

macrumors 65816
Jul 30, 2009
1,250
498
Colorado
I believe the WiFi connection will activate DHCP for devices connected to the ethernet. try using DHCP instead of manually signing n address to that interface.

If the WiFi interface gets confused, it will likely shutdown or reset to try to resolve the conflict.
 

jonj64

macrumors newbie
Original poster
Dec 14, 2018
2
0
Japan
When I try the DHCP setup I can't get connected past the Macbook Pro. See attached, the USB 10/100/1000 is yellow vs green. I am pretty sure that this all has to do with NAT but not sure if it is insurmountable.
[doublepost=1544852515][/doublepost]Thanks to your advice, I tried DHCP with manual address option. Once I set it at that, the ROKU started to work! And my wifi on the Macbook is running just fine (am typing this from the Macbook).

Thanks for the nudge!
 

Attachments

  • dhcp.png
    dhcp.png
    185.3 KB · Views: 189
  • dhcp with manual.png
    dhcp with manual.png
    194.2 KB · Views: 156
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.