Internet Connection sharing from MBP to iPhone

Discussion in 'Mac Apps and Mac App Store' started by vanmacguy, Oct 15, 2007.

  1. vanmacguy macrumors 6502a

    Joined:
    Aug 13, 2007
    Location:
    Not where you live.
    #1
    Hi all,

    I am running a C2D MBP on an Ethernet network and am trying to set up Internet Connection Sharing (ICS) from it to my iPhone.

    My iPhone is running 1.0.2.

    Does this just not work? I can get it to see my shared network, it has an IP address and Router address, etc. The Ethernet is running on DHCP. iPhone shows the little Airport symbol but nothing works.

    Any ideas? I've been trying to do this for a couple of weeks now, I had it working once but after a few hours it quit and won't work anymore.

    Does anyone have this running? And if so, how did you do it and and what settings did you use?

    Cheers.

    David.
     
  2. tfs1911 macrumors newbie

    Joined:
    Oct 18, 2007
    #2
    same problem

    I am having the EXACT same problem. Any clues are appreciated. I've tried different MBPs also as we have several in the office.
     
  3. camsoft macrumors regular

    Joined:
    Nov 11, 2007
    Location:
    Brighton, Sussex, UK.
    #3
    I also am having the exact same problem trying to share my MacBook's Ethernet connection over Airport to my iPhone. It shows up on the iPhone, even connects and displays the IP address etc. The signal strenth is maximum. But when I try to use MobileSafari it just does not work.
     
  4. camsoft macrumors regular

    Joined:
    Nov 11, 2007
    Location:
    Brighton, Sussex, UK.
  5. samlic macrumors newbie

    Joined:
    Nov 16, 2007
    #5
    I have the same problem, I was on Tiger, and now on Leopard, both can't make it works.

    BUT, It worked for me only once, I share my Ethernet to the Airport, I try to alternate some sharing setting inside the preference, eg. turning the internet sharing on/off, changing the name of the airport, and suddenly it works on my iPhone, but only once ,never again.

    I am still digging on it. sometimes it just works for a few KB of data, eg. stop loading a page in the middle.

    The bug should be on iPhone. coz internet sharing works fine on others computer.
     
  6. fabiocaseri macrumors newbie

    Joined:
    Nov 21, 2007
    #6
    Same problem for me..
    Anyone got this working? :confused:
     

Share This Page