Internet connection via ethernet keeps dropping?

Discussion in 'Mac Basics and Help' started by blainet, May 1, 2007.

  1. blainet macrumors newbie

    Joined:
    May 1, 2007
    #1
    I'm fairly new to OSX, and I'm having a problem I can't figure out.

    My internet has been disconnecting lately... it'll work for about 5 minutes, and then I will loose connection.

    This is now a router or ISP issue, technical support agents have verified all of my hardware and lines.

    Rather, it seems to be a problem with OSX. If I unplug, replug the ethernet cable, or change the network location, (basically anything that would cause the system to reapply network settings, as far as I can tell,) it will reconnect, but only for another few minutes.

    I've tried to use several fixes for this. Manual Ip's, automatic settings, using the mac assist prompts to create new network locations. Even switching to the Airport... all with the same result; I will connect for just a few minutes, and then loose connection again.

    I am running on the newest model (duo-core 2) intel 20-inch iMac. I have just recently updated to security update 2007 -004 and I believe this is at the root of my problems, as I had no problems whatsoever before that. Ive found out that several people have had issues with their wireless connections after the update, but I haven't come across another example of my problem.
    I am currently downloading the Mac OSX Combo 10.4.9 Combo installer to test if this update is the issue.

    I do not believe that this is a hardware issue, neither the ethernet, or Airport wireless connections will last longer than a few minutes... and both work after changing the settings.

    Is there something simple that I'm missing? I really hope so... I've never had this much trouble with the mac before this... Thanks!
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    Strange problem mate, so keep us posted on how the combo update goes. In the meantime, what apps do you have running?
     
  3. Super Macho Man macrumors 6502a

    Super Macho Man

    Joined:
    Jul 24, 2006
    Location:
    Hollywood, CA
    #3
    I'm guessing you are behind a broadband router? Compare your IP address / other network settings in System Preferences -> Network when your connection is working to the same setting when it isn't. Are they all the same? If the IP address is ever 169.x.x.x, something is wrong, probably with the router settings. Check DHCP in the router control panel.
     
  4. ericssonboi macrumors 6502

    Joined:
    Mar 15, 2005
    #4
    What kind of router is it?
    Ethernet / Router combo?
     
  5. blainet thread starter macrumors newbie

    Joined:
    May 1, 2007
    #5
    The combo updater has had no effect on my system. I've even tried AppleJack, and those routines didn't help at all.

    The IP is the same when it is working, as when the internet drops out... it's a 206.xxx.xxx.xxx number. Although, I did add a manual router address (192.168.1.xxx) which gave me the same results... it worked for a few minutes.

    The problem started at the end of last week, so as far as software, I've removed two programs I've installed in the last month, ArtRage 2, and EyeTV software which have had no effect on the problem... (I've un-installed them using AppDelete, and repaired permissions.) The only other change to the system would have been the 2007-004 security update (which was installed last week as well.)

    My router is a 2wire gateway (2700 series,) which is sold by telus here in Canada. As far as identifying the ethernet hardware, I'm not sure what you are looking for specifically, but using system profiler, it lists the device name as 'en0.'

    Again, the router hardware seems to be ok. A telus agent hooked up to my router and could use the internet when my imac could not. I will be hooking up my old windows laptop tonight for more testing...

    Something else that I can add, is that I've run network diagnostics when the connection is out, and it gives me this curious message:

    "This computer appears to have a working internet connection but cannot find 'www.apple.com.' You may have typed the address incorrectly."

    I began to think it was a browser problem, but I checked firefox, safari, and itunes to try to connect... again with the same results.

    So I'm running out of ideas... My next move tonight is to back up all of my data, and then completely reinstall OSX on the machine. If that does not fix my problem, then I guess it's a hardware related issue, and the timing is simply a coincidence.
     
  6. Black&Tan macrumors 6502a

    Black&Tan

    Joined:
    Mar 4, 2004
    #6
    I would take a look at the router...maybe the firmware can be flashed to a newer or older version. I had a similar issue a while back, and found out the router needed the firmware downgraded. The best place I've found to discuss telecommunication issues is:

    http://www.broadbandreports.com/

    I did a quick search on the 2wire gateway router and came up with a large number of hits. I can't vouch for everyone on the site, but when it came time to hook up my LinkSys router to SBC DSL, it was invaluable. Lots of knowledgeable people in the LinkSys section. Just make sure you come back here after solving your problem!
     
  7. odinsride macrumors 65816

    odinsride

    Joined:
    Apr 11, 2007
    #7
    I'm having this same problem with my Macbook. I have my PC hooked up to the same switch/router, with absolutely no problems. The connection just drops completely on my Macbook. It seems to happen after I type my password to unlock the computer.

    Have you resolved your issue?
     
  8. MagicUK macrumors regular

    MagicUK

    Joined:
    May 12, 2007
    Location:
    Hampshire, England
    #8
    Okay so;

    A= Your Laptop
    B= Your Friends Laptop
    --------------------------
    X= The Ethernet cable
    Y= Internet Cafe Ethernet cable

    A + X = Fail
    B + X = Pass
    A + Y = Pass
    B + Y = Pass

    This would tend to prove the port on your laptop, and the cable are good. Now you need to check the next common element, the DSL router. Are you doing any MAC Address filtering on the router?
     
  9. thesnyders macrumors newbie

    Joined:
    May 29, 2007
    #9
    Same issue

    I am having the same issue with both the hard wired connection and wireless. this is currently my 3rd router and the issue has occured with all 3.

    Brent
     
  10. astewart macrumors member

    Joined:
    Sep 12, 2006
    Location:
    Charlottetown
    #10
    Update the firmware on your router....

    Check the Routers manufacturer website to see if you have the latest firmware update, (Report to specific Router Model as well)
     
  11. scott85213 macrumors member

    Joined:
    May 19, 2007
    #11
    I don't have a mac yet, but i'm sure they have powersave features like other computers. I'm also assuming this is a macbook, though it may not be. But if it is, maybe you have possibly both wireless and wired turned off when it is not plugged into the wall. These options are standard in literally every laptop.
     
  12. josepho macrumors regular

    Joined:
    Mar 12, 2004
    Location:
    Surrey, England
    #12
    I don't think this could be the cause of the OP's problem.

    First of all, I can't remember ever having seen such an option within OS X (although it would take two clicks to turn off wireless network access anyway).

    Secondly, the fact that it is happening consistently after a couple of minutes of use would not point to it being anything to do with being attached to mains electricity.

    Thirdly, the OP would be able to tell at a glance whether or not he was connected wirelessly (the icon is - on a lot of people's Macs at least - the top right hand corner of the screen at all times).

    Fourthly, I believe that the OP said he had an iMac, which isn't a notebook and so wouldn't - presumably - have such features.
     
  13. ejcoson macrumors newbie

    Joined:
    Jul 23, 2008
    #13
    After days of fiddling...

    I have had the problem for days and I could not rest until I got it working... I hope it works for others.

    What I Did:
    -My connections are 2 Power Macs (Ethernet to Router to Cable Modem) and 1 PC (Wireless)
    -Since the the iMac kept dropping, I opened Airport on the iMac and used the wireless connection (worked seamlessly).
    -Today I realized that if the settings for the wireless connection was working, why not just use the settings?
    -I copied the DNS Servers from the Wireless connection - found under System Preferences>Network>Location:Wireless Network - Show:Airport, and applied them to the DNS servers on Location: Internet Connection - Show: Built-In Ethernet.
    -Then I changed the Configuration to Using DHCP with manual Address to the port that I plugged the ethernet cable to on the router (in my case ---.---.1.101)

    It is still holding up and sitting pretty strong... hope this helps someone.
     

Share This Page