Internet Connectivity Problem

Discussion in 'MacBook Pro' started by brontosaurusrex, Dec 6, 2010.

  1. brontosaurusrex macrumors newbie

    Joined:
    Dec 6, 2010
    #1
    I recently moved to a new place with a new cable company, and I've been having problems with the internet here. When I am browsing online, my computer will randomly drop its connection to the internet- my airport status will read connected, the wireless signal shows strong, but my computer is no longer connected to the internet. When I turn off my airport and turn it back on again, the problem is fixed, though it often happens again within a few minutes, or can last for several hours before this happens again. This also happens on my iphone, though not on my girlfriend's newer macbook pro. I'm just wondering what the source of the problem could be-

    Should I just change the channel on my router? i got istumbler and noticed that my next-door neighbor- i live in a row of townhouses- is on the same channel as I am. could the interference be causing this kind of problem? I haven't done this yet because I have lost my scrap of paper with the security code written on it, but will scrounge it up if this could be a solution.

    Might this be a problem with the router hardware? The fact that my girlfriend's computer doesn't have this problem makes me wary, but could her newer computer be able to handle this better than mine?

    Could this be a problem with the computer itself? as a red-blooded male, i sometimes visit some sites that are a bit nsfw- could something be going on from that? (my girlfriend, i'm pretty sure, never does that sort of torrid browsing, so perhaps that is the source of the difference?)

    OR could it be something else that i'm unaware of?

    any help that could be offered would be much appreciated.
     
  2. EarthDawn macrumors 6502a

    EarthDawn

    Joined:
    Feb 18, 2008
    Location:
    Long-eye Land, NY
    #2
    I wish I could help ... but theres about 4-5 threads in this forum alone in the past day ....

    Someone said it may be the last OS update... but it is definitely annoying.
     
  3. Stvwndr219 macrumors 6502

    Joined:
    Jan 26, 2009
    #3
    I'm still looking for the answer but it seems to be the OS update - had no problems on 10.6.3 but it popped up in 10.6.4 and 10.6.5...
     

Share This Page