Internet cutting out in bootcamp, fine in osx

Discussion in 'Windows, Linux & Others on the Mac' started by Kissaragi, Jul 4, 2010.

  1. Kissaragi macrumors 68020

    Joined:
    Nov 16, 2006
    #1
    Ive been using windows 7 32bit to play battlefield bad company 2 via steam for about a month now with no problems. A week or so ago, i booted into bootcamp, loaded bc2, found a server, played for a few seconds then started noticing major lag. After a couple of minutes of this, the connection would be lost with the server and very shortly after the internet light on my router would go from green to red. I boot back into osx and the connection goes back up.

    It now does this every single time i boot into bootcamp and the connection is always perfect in osx.

    I tried reinstalling windows 7 (64bit this time) and the problem is still there. Anyone have any idea whats going on?
     
  2. Groundhogs macrumors newbie

    Joined:
    May 30, 2010
    #2
    I get this to, well the dropping connection, but it works fine in OSX. Only thing i can think of is the drivers in windows and some problem with that as my brother's laptop doesn't drop in connection
     
  3. Nevering macrumors newbie

    Joined:
    May 17, 2009
  4. Kissaragi thread starter macrumors 68020

    Joined:
    Nov 16, 2006
    #4
    Anyone have an idea about how to fix it? Ive ordered a new router and i was thinking i could buy a new pci ethernet card just for windows if it was a bootcamp driver issue.

    That is if i can find one that works with windows 7 64bit
     
  5. Kissaragi thread starter macrumors 68020

    Joined:
    Nov 16, 2006
    #5
    Ive found a belkin ethernet card thats meant to work with windows 7 64bit so ill give it a go and see it it solves the problem.
     
  6. Kissaragi thread starter macrumors 68020

    Joined:
    Nov 16, 2006
    #6
    So the router turned out to be for cable connections not adsl (even tho amazon dont mention this anywhere on the product page) and the ethernet card wont fit, i thought pci and pci express slots were the same just different speeds, but i was wrong. This is not going well, lol
     
  7. Kissaragi thread starter macrumors 68020

    Joined:
    Nov 16, 2006
    #7
    After a day spent on the phone to talk talk, apple and finally microsoft (weirdly, microsoft had by far the best customer service people!) it seems to be a 3rd party app, driver or service causing my problems. In safe mode my connection is fine. Im working my way through trying to find out which app is to blame, ill let you know when i find out
     
  8. cable2112 macrumors newbie

    Joined:
    Sep 24, 2008
    #8
    Ever figure it out?

    I am having the same problem, did you ever figure out what was causing your connection problem?
     
  9. Kissaragi thread starter macrumors 68020

    Joined:
    Nov 16, 2006
    #9
    Hi, in the end i went out and bought a new router, it solved the problem right away. It was just a basic N wireless linksys from comet for about £35 so it wasn't anything fancy. I assume the router from my isp was shoddy or faulty and their technical support is just terrible (in fact the whole isp was terrible!)

    Good luck with it, it drove me up the wall so i hope you solve it soon.
     

Share This Page