Internet does not work under OSX, but fine in XP on Parallels

Discussion in 'macOS' started by daverulz, Oct 18, 2010.

  1. daverulz macrumors newbie

    Joined:
    Oct 18, 2010
    #1
    I am having an issue that I can't resolve. Starting this morning, I lost my internet connectivity in both Firefox and Safari (OSX 10.5.8 on my Macbook pro) The odd thing is, that using my parallels installation of XP, I'm able to access the internet without a problem, that's how I'm making this post. I don't have any proxies set up either in firefox or the network preferences under OSX or XP. I'm able to connect to and access all files on the network, I just can't get to the internet. This has really got me baffled. I ran network utility and got 100% packet loss, and it's fine under XP. Any ideas?

    I've attached a picture of the ping from XP and the Ping from Network Utility, done basically simultaneously
     

    Attached Files:

  2. jonbravo77 macrumors 6502a

    jonbravo77

    Joined:
    Feb 20, 2008
    Location:
    Phoenix, AZ
    #2
    Look in your Network settings on the Mac and see what Location settings it is using. Parallels likes to over take the Mac network settings and could cause some issues. Also, in Parallels do you have the network set to shared or bridge?

    As a side note, I don't like Parallels. It's a system hog.
     
  3. daverulz thread starter macrumors newbie

    Joined:
    Oct 18, 2010
    #3
    I'll check those things and report back, the thing is, this has worked for well over a year. I don't use parallels much at all, the only reason I'm using it is because I realized that it was not our internet connection/network at work that was the problem, it was my machine. Parallels is not the problem here, it's something else.

    I'm using the automatic location settings, which again I've been using for over a year without an issue at this job.

    Also, Parallels is set to use shared network settings.

    Again, this isn't a parallels issue, without Parallels running at all I was not able to connect to the internet with Firefox or Safari, even though I was able to access all network drives and other computers on the network. Only after seeing on other machines that there was no problem with the internet connection did I try firing up Parallels to see if the internet would work, and it did. Wierd.

    In trying to fix the issue I deleted some files out of the preferences in the Library folder. I went ahead and restored them from my last time machine backup. I also repaired permissions off of the OSX install disc since Onyx told me there were issues that needed to be repaired from the disc.

    Any additional help or insight is greatly appreciated! Thanks!

    Dave
     
  4. bbazzahh macrumors newbie

    Joined:
    Jun 3, 2010
    #4
    Are you able to ping the router on the Mac Side?

    What happens if you ping the DNS Server of Apple ?
     
  5. daverulz thread starter macrumors newbie

    Joined:
    Oct 18, 2010
    #5
    Not that this helps anyone understand what was wrong, as I don't even know. But after repairing permissions off of the OSX install disc last night all is well. No issues at all at work today. Thanks for the help, I'm just glad it's resolved as it was a major PITA to have to use Parallels just to access the internet.

    Thanks again guys!
    Dave
     

Share This Page