Internet Explorer for Mac

Discussion in 'Mac Apps and Mac App Store' started by ARF900, Mar 14, 2010.

  1. ARF900 macrumors 65816

    ARF900

    Joined:
    Oct 30, 2009
    #1
    Im sure for very few people request this, but I am looking to see if internet explorer might be available for 10.6? Anyone know where I could possibly get it?
     
  2. MacDawg macrumors Core

    MacDawg

    Joined:
    Mar 20, 2004
    Location:
    "Between the Hedges"
    #2
    No, it is not
    You can try running the Window version with Crossover if you really need it
    Or faking it with the Safari Developer's menu if you need to fool a site

    Old versions of IE found here
     
  3. Chundles macrumors G4

    Chundles

    Joined:
    Jul 4, 2005
    #3
    Internet Explorer 5 was the last version made for the Mac. It hasn't been updated since about 2002 and as far as I'm aware is no longer available to download.

    What's the reason for wanting such a horrible product?
     
  4. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
  5. ARF900 thread starter macrumors 65816

    ARF900

    Joined:
    Oct 30, 2009
    #5
    I cant explain it, but on my home network, IE8 is faster, and more consistent than Safari, Firefox, or chrome. I have no idea why.
     
  6. thejadedmonkey macrumors 604

    thejadedmonkey

    Joined:
    May 28, 2005
    Location:
    Pennsylvania
    #6
    IE was such a horrid piece of crap, and so they had to outdo themselves, and thus you have IE8. Safari and Firefox need a reboot, while MS outdid themselves. Unfortunately, there's no IE for mac anymore.

    I'd look at Google Chrome.
     
  7. ARF900 thread starter macrumors 65816

    ARF900

    Joined:
    Oct 30, 2009
    #7
    chrome is just as bad as Safari and Firefox, on other networks they run perefctly, but on mine i constantly get server connection errors, incorrectly loaded pages, and bad performance.
     
  8. MacDawg macrumors Core

    MacDawg

    Joined:
    Mar 20, 2004
    Location:
    "Between the Hedges"
    #8
    Sounds like a problem with your network or router, not with the browser then
     
  9. ARF900 thread starter macrumors 65816

    ARF900

    Joined:
    Oct 30, 2009
    #9
    well then why does IE work perfectly, I have a decent connection and ping about 90 ms
     
  10. MacDawg macrumors Core

    MacDawg

    Joined:
    Mar 20, 2004
    Location:
    "Between the Hedges"
    #10
    That I cannot tell you, but if they run perfectly on other networks and not yours, then I would target the network, not the browser

    You may need to troubleshoot your network settings on your Mac
    You can try OpenDNS or some other connection

    Check out this thread too
     
  11. ZazenZach macrumors member

    Joined:
    Dec 23, 2009
    #11
    Though I'm a mac user, I'm not a fanboy. So I use many microsoft products from time to time.

    But Internet Explorer? Why in the heck would you want that? I mean, out of all the tons of browsers, you chose IE, the worst of them all? WTF?! I mean, chrome vs firefox vs Opera seems like a reasonable debate, but ie is complete trash
     
  12. ARF900 thread starter macrumors 65816

    ARF900

    Joined:
    Oct 30, 2009
    #12
    Thanks ill try that when i get some time

    read the thread
     

Share This Page