Internet in Parallels NOT WORKING?

Discussion in 'Windows, Linux & Others on the Mac' started by stagecustom, Feb 5, 2007.

  1. stagecustom macrumors regular

    Sep 7, 2006
    Hey guys, i am having alot of trouble with parallels, the internet is not working in it, i am using airport to a d-link router, i used to use bootcamp, but opted not to because well this will sound stupid, because i don't have an apple keyboard, and when i boot with bootcamp and xp installed it always goes to windows, my mac mini doesn't recognize my option key i guess:rolleyes: :mad:

    anyway, i have xp running in parallels, no internet works, i have web sharing turned on in sharing, also have windows sharing on. anyway I can't seem to get on the internet in windows, and as weird as this is, i NEED to download some music for my dad but the company he's buying from will only do it if he has xp and windows media player. they could send him the cd's, but it will cost him 15$ more or something ridiculous, my dad said he would buy me some ipod games off itunes if i do this for him. SO THAT BEING SAID: once you guys help me get onto the internet, how will i get them to his mac? email could be tideous, can i burn a cd in parallels?

    before you tell me to go use bootcamp (which i could because i do have access to an apple keyboard thats on my moms and dads comp) BUT i tried after my attempt failed with parallels, and it said it couldn't partition for some reason!?! I went to DU and repaired it and its smart verified ect and it said it was repaired but it still won't, it says i need to repair it!

    PLEASE HELP ME GET THIS WORKING! ALSO THIS would be ideal, if i could just run xp via bootcamp from my external 250gb USB drive. that way i wouldn't have to deal with this partition sh*T.

    Let me know guys. i really want this working, and i want some ipod games... please help!
  2. SilentPanda Moderator emeritus


    Oct 8, 2002
    The Bamboo Forest
    Have you installed Parallels Tools yet? Once you are in Windows there should be an option to do that in the menu bar at the top of your screen in OS X. This will launch the Parallels Tools installer in Windows. Not sure if this will fix it but it's worth a shot.
  3. yellow Moderator emeritus


    Oct 21, 2003
    Portland, OR
    You don't need websharing or internet sharing. In fact, internet sharing is probably conflicting with your router. Turn it off. Web sharing is for running a webpage locally and has nothing to do with network other computers.

    Beyond that, are you filtering by MAC address on the router? If so, you need to either add the MAC address of parallels, or change the Mac address to match that of your AirPort card MAC address.
  4. jonaseriksson macrumors member

    Jun 5, 2005
    are all the settings in parallels correct?

    are you on wireless with a mac-adress lockdown?
  5. stagecustom thread starter macrumors regular

    Sep 7, 2006
    hmm. i just have it set up normally, i haven't touched the IP's or any settings on the router, i just have everyone in my house on wireless. and my mac internet works, whats up with parallels? and no i haven't seen anything about the tools, its supposed to come up when windows is booted but in a mac window?:confused:
  6. Makah macrumors newbie

    Nov 2, 2009
    re: Internet in Parallels NOT WORKING?

    The same thing happened to me, and I went into the Network Preferences in my mac, got the IP address from Airport > Advanced > TCP/IP and then I went into my Parallel - Guest internet setting, changed the configure to Using DHCP with manual address, and entered the Airport IP address there. That fixed it for me, hope that helps you as well.

    Makah Leal
    Soliant Consulting

    Attached Files:

  7. drbillpalmer macrumors newbie

    Apr 21, 2010
    I struggled with this problem all day and tried every potential solution I could find on line - nothing worked.
    What finally did work was to uninstall the parallels tools (not just reinstall, but actually remove using windows control panel) and then reinstall.
    Hope it works for others.

Share This Page