Resolved Internet is working fine, but iMac has self-assigned IP and can't connect

Discussion in 'macOS' started by sara.sia, Mar 14, 2011.

  1. sara.sia, Mar 14, 2011
    Last edited: Mar 15, 2011

    sara.sia macrumors newbie

    Joined:
    Mar 12, 2011
    #1
    1. I am using my brand new iMac with a Linksys AT&T router. Have been fine with my internet for months.

    2. Today I tried connecting my Airport Extreme Base Station (old model from 2002) to my Linksys router

    3. At the installation process in Airport Utility, I selected to "replace my existing network with my airport" (I think this was my mistake here)

    4. Things started looking funny fast, I lost my Linksys connection and also my Airport connection - no internet

    5. I immediately unplugged the AEBS and reset my Linksys router, ditching the whole AEBS

    6. THE MAIN PROBLEM: My husband's SONY Vaio and my Macbook Pro both can still connect to our Linksys wireless signal, but my iMac CANNOT CONNECT (This is the computer I completed the set up of my Airport Utility with the AEBS originally)

    The computer says that "airport has the self-assigned ip address and will not be able to connect to the internet"

    However, I can connect to the internet on EVERY OTHER computer in my network except one: the computer I originally installed the AEBS on.

    7. I have tried everything (and read all the forums!) including:
    -Verified that we are configuring the IPv4 using DCHP
    -Configuring the IPv6 automatically

    - Then I tried assigning a manual IP address within the range that my router owns and specifies

    also tried this (per another forum):
    1. Go to Mac/Library/Preferences/SystemConfiguration
    2. Delete the following:
    a. Com.apple.airport.prefrences.plist
    b. NetworkInterfaces.plist
    c. Preferences.plist
    3.Shut down computer
    4.reset PRAM

    NOTHING HAS WORKED. How can I get my iMac to claim the proper IP address?

    I am absolutely baffled at this, and I am a very proficient tech. I have never seen anything like this before. PLEASE HELP! What is going ON???
    sara.sia is online now Report Post Edit Message
     
  2. ScoobyMcDoo macrumors 65816

    Joined:
    Nov 26, 2007
    Location:
    Austin, TX
    #2
    So, just curious, if it wasn't broken, why did you add the AEBS


    I'm not sure what you actually did here - did you connect them with an ethernet cable? Or extend the connection wirelessly?

    So, when you click on the airport icon, what network does it say it's connected to?
     
  3. stevep macrumors 6502a

    stevep

    Joined:
    Oct 13, 2004
    Location:
    UK
    #3
    Not sure I can be much help as I know nothing really about Airport Express setup, but it sounds to me as though your previous attempt to set the AE up with the Linksys has resulted in the iMac trying to contact the AE rather than the Linksys.

    1. Can you connect with an ethernet cable?
    2. Check that the Linksys doesn't have MAC address filtering set up.
    3. Do a ping test to see if you can communicate with the router
    (Terminal > ping -c4 192.168.1.1 (or whatever your routers ip address is)
    4.Suggestion from Apple discussions:
    Go into System preferences
    Then Network preferences
    Click on "Advanced" button in bottom right corner
    Go to "Proxies" tab
    Uncheck (disable) the "Use passive FTP mode" box
    5. Check your Airport Utility settings to make sure it's not confusing the iMac/Linksys connection
    6. Set up a new Location in System Prefs, Network

    Best I can do I'm afraid, and apologies if some of this is already obvious to you.
     
  4. r0k macrumors 68040

    r0k

    Joined:
    Mar 3, 2008
    Location:
    Detroit
    #4
    sara, there are some missing details that would allow me to help with your situation. i will make some sweeping assumptions...

    1 - your imac is connecting wirelessly
    2 - when you tried to set up your aebs, your mac "got married" to your aebs and forgot all about your linksys


    1 - click on the wifi icon and you should see the network ssid offered by your linksys. click on it and join it
    2 - click on the wifi icon, pick open network preferences, then pick advanced, then find the name of the network created by the aebs and hit "-" to delete it from the list of networks your imac remembers

    If your linksys is fairly new, I suggest you sell the aebs on ebay. I'm sure there is somebody who wants a 2002 aebs but you don't need one if you have a newer router that you like. If you don't like the linksys, I suggest you buy a newer aebs so you get newer features like 802.11n and the ability to set up a guest network for all those virus laden windows boxes your friends bring over. Note that if you want to extend a wireless network, the router and the extender have to be the same brand. You would need an aebs and an airport express to extend it. But you can't use an aebs or ae to extend a network created by a linksys router. In short, there was no reason at all to power on and try to use the aebs unless you wanted to replace your linksys router. BTW, using an ae to extend an aebs wireless network does not involve running any wires. The ae joins and extends the aebs network wirelessly.

    hope this helps...
     
  5. sara.sia thread starter macrumors newbie

    Joined:
    Mar 12, 2011
    #5
    Thanks for your help folks!

    I had tried doing all that you suggested before - however this I found to be the solution:

    - The only preference I hadn't removed was the keychain memory of my SSID WEP Password (Even though I had deleted the network off the memorized wireless networks)

    - I deleted the saved WEP password from the list. When I tried to reconnect this time, it asked for the password anew and after typing it in, it grabbed a new IP address from the router and VOILA I am connected.

    Thank you!
     

Share This Page