Internet keeps cutting out

Discussion in 'Mac Basics and Help' started by Jay-Producer, Mar 4, 2010.

  1. Jay-Producer macrumors newbie

    Nov 29, 2009
    Ive now got to the point where I want to switch to PC.

    Ever since I've had my mac book pro the internet keeps disconnecting. 3 years this has went on for now. I'm sure you'd all agree that this is not good for apple mac.

    Ive moved home 4 times so there definitely is no interference. 3 different countries also.

    Ive tried every possible solution. Turned all electrical equipment off apart from the router and still no joy.

    Around every 1-10mins (depending on how lucky I am) the internet will disconnect. I cant re-connect so I have to re-start my computer every time.

    Ive tried changing the channel. Some don't work at all.

    Any suggestions?
  2. Intell macrumors P6


    Jan 24, 2010
    The Macbook /Pro wireless issues have been widely documented. Most people say its the kind of wireless router you have. Apple Airport ones seem to be the best. One thing you could try is changing the wide channel settings on your current one. I did that to my Belkin one and it fixed my wireless problems. What kind of wireless router do you have?
  3. NewMacbookPlz macrumors 68040


    Sep 28, 2008
  4. Jay-Producer thread starter macrumors newbie

    Nov 29, 2009
    Netgear, Wahts the best setting? ive tried a few already.

    Too expensive. £50 p/hr. No thanks.
  5. forcefieldkid macrumors 6502

    Jan 20, 2010
    If you're in the UK (£?) and out of warranty/Applecare, you can always have a look in the Yellow Pages ( and find a local repair company that deals with Macs, they'll usually come out and diagnose the problem for free. No fix no fee for most of them too.
  6. ss957916 macrumors 6502a

    Jun 17, 2009
    I've had the same issue with my last two MBPs and I've also lived in different properties (2). I have an Airport Extreme, so Apple routers make no difference.

    I've taken my current MBP to Apple twice and, inevitably, when it's in the store, it works fine so I've been sent away.

    Like the OP, I will be seriously considering a PC when I come to update my computer.
  7. Queso Suspended

    Mar 4, 2006
    Try locking the router's wireless to a particular standard, for example "g only". That used to work when I had one. You may also want to check the router is running the latest firmware.
  8. Intell macrumors P6


    Jan 24, 2010
    It could also be the kind of security your using. Try none, wep, wpa, and wpa2. You might find the correct one. For wpa/2 you should set it as tkp+aes for a better chance of finding the correct match.
  9. ARF900 macrumors 65816


    Oct 30, 2009
    Why didnt you take it in when you were first having this problem? Have you had the same router all this time? You should find a friend with a PC and see how it works on your router.
  10. Jay-Producer thread starter macrumors newbie

    Nov 29, 2009
    Same company but not exactly the same router. All Belkin routers.

    Ive only just moved to a new country so don't know anyone here.

    I had a 1yr warranty and called up apple mac who said it had nothing to do with their computer and not to take it in for a check up. Complete bollox! nothing but problems with apple mac. Last time I'm buying a £2,500 computer.

    It only uses WPA security. So no choice in the other options. I'm not turning off security, i shouldn't have to.

    I don't have static IP - I have never found that static or non static make any difference.

    My partners computer uses 'n' I use 'g' so not an option. When we were both using 'g' I still had the same problems, so that doesn't seem to be the problem.

    Whats the best settings to have the router on? 11 I know is one, but what are the others so I can check them all out.
  11. Jay-Producer thread starter macrumors newbie

    Nov 29, 2009
    Do you know the best settings to use?
  12. R.Perez macrumors 6502


    Feb 16, 2010
    Philadelphia, PA
    I had similar problem with my new quad core iMac.

    For whatever reason, after a couple weeks it stopped disconnecting.

Share This Page