Internet only works in safe mode

Discussion in 'macOS' started by AF443XM, Aug 2, 2010.

  1. AF443XM macrumors newbie

    Joined:
    May 27, 2006
    #1
    I've been having problems with my mid-2009 10.6.4 MacBook Pro for the past week or two. My internet is very erratic, working alright at first and then becoming excruciatingly slow. Sometimes a restart helps for a few minutes and sometimes it doesn't. Pages won't load and files won't download more than 0.5 - 2.0 kb/s. This is in Safari, Firefox, Mail, and any other internet related application. It's definitely not a browser-specific problem.

    I've tried using Google's DNS servers, clearing caches, resetting Safari, reapplying the 10.6.4 combo update, setting up a new user account, etc. Nothing works for more than a few minutes.

    What does work, though, is booting into safe mode (by holding shift on startup). The internet is speedy and 100% fine then. But once I go back to normal mode it dies again.

    What could cause the internet to be okay in safe mode and not work normally? Thanks!


    [Edit: Forgot to mention I also tried repairing permissions, resetting PRAM & SMC, and Onyx.]
     
  2. qbarkhuizen macrumors newbie

    Joined:
    Sep 29, 2011
    #2
    Internet only works in safe mode

    I have exactly the same problem; I got my Macbook Pro in July 11.

    I've also done what you have to try make it work again.

    I've been able to repair this problem twice.
    First time by upgrading to Mac OS Lion.
    Second time by restoring my complete machine from Time Machine!

    However I think it may be installed software that creates the problem.
    Do you have Parallels on your machine?
    I have a feeling that my problems started happening after I put Parallels on.
    I have another Mac in the office and it's been operating fine without a problem but it doesn't have Parallels on it. It also uses the old Snow Leopard OS.
     
  3. xenflex macrumors newbie

    Joined:
    Sep 1, 2012
    #3
    I'm having the exact same problem with my MBP running 10.6.8.

    I am running it in safe mode right now and am now able to access the internet. There must be a third party application which automatically boots on start up which prevents internet access. What I want to know is how to identify it and get rid of it?

    Does anyone know how I can fix this problem?

    AF443XM and qbarkhuizen, did either of you manage to fix this problem? If so could you explain to me how you did it?

    Thanks!
     
  4. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #4
    A safe mode boot bypasses anything in your startup items list, so that is likely the culprit. Go to System Preferences and in Users & Groups click on your username and see what is in your Login items that may be causing this.
     

Share This Page