internet painfully slow

Discussion in 'MacBook Pro' started by woohoo, Jul 5, 2010.

  1. woohoo macrumors newbie

    Joined:
    Feb 1, 2010
    #1
    I got my first macbook pro about a month and a half ago, and everything has been working flawlessly. Recently however I have been experiencing extremely slow internet. It hasn't been a problem until recently when I noticed extremely slow web surfing. The download speeds seem to fine, but surfing the net is painful. I have firefox along with safari and both are equally slow. It is faster to surf some sites using my phones 3g service then my wireless internet. I have looked at mroogle and have tried some of the solutions on there and none of them seemed to work. I am using a linksys E1000 router and my airport has full bars. I don't know how run a speed test so I am not sure what my internet speeds are. If any of you guys have any ideas of a solution it would be greatly appreciated. Also, I am not the best with computers, so if the solution is complex please give me a step-by-step.


    Thanks,

    woohoo
     
  2. Tim018 macrumors regular

    Joined:
    May 31, 2009
    #2
    you can run a speed test at 2wire.com and then click on "speed meter"

    I had the same problem when i got my macbook too, i found that what it took was upgrading the firmware on the dsl modem or the wireless box, cant remember which. either way i would look up both your modem and wireless box (unless the router provides both obviously) and check the net for any firmware updates and such.

    you might also simply consider resetting the box and restarting the macbook at the same time, i found that fixed the problem too, but only temporarily till i found the firmware fix...

    hope that helps...
     
  3. woohoo thread starter macrumors newbie

    Joined:
    Feb 1, 2010
    #3
    Thanks for your response I will try those solutions out. I just ran a speed test at 2wire.com and got a result of 1.5 Mbps. Is that slow, fast, or what.

    Thanks,

    woohoo
     
  4. JCCash macrumors regular

    Joined:
    Apr 20, 2008
    #4
    Is that your upload or download speed? Mine is very slow access in Central Florida using Brighthouse. Download 3.00 Mb/s - Upload 0.95 Mb/s - ping 57ms

    We pay $45.00 a month. I'd like to switch to UVerse but it's not an option for our block.
     
  5. Tim018 macrumors regular

    Joined:
    May 31, 2009
    #5
    Depends on what your paying for at your house. We pay for 1.0mbps dsl at our house, and when i run 2wire it comes out to almost exactly that. So 1.5 mbps sounds good to me, but it depends on what your paying for. I'd say it takes from 4-8 seconds to fully load a webpage on my connection. So yours should be somewhere around there
     
  6. snailmale macrumors newbie

    Joined:
    Feb 23, 2010
    #6
    hmm this thread inspired me to test my internet speed. and it seriously worries me that my netbook that cost a 1/4 of what my mbp cost does 2.67Mbps while the mbp does 1.19Mbps downloads.

    I'm running on an old linksys router (WCG200) and there are no software updates to be made. Is this normal? the 2 laptops are more or less side by side. Is there any way to speed up the internet on my mac?

    I'm not sure of what my brother is paying for, but it shld be at least 8Mbps, if not 12.

    Edit: I checked my family's subscription plan, it should be for 16Mbps.
     
  7. woohoo thread starter macrumors newbie

    Joined:
    Feb 1, 2010
    #7
    We are paying for a max download rate of 7 mbps and upload rate of 512 kbps so i am assuming we should be going a lot faster then we are. I think the problem is with our router not the internet provider. All the firmware seems to be up to date so i believe there is a problem with the router because all of the computers in our house are slow right now. So i am going to re-configure the router and see what happens.
     

Share This Page