Internet Recovery Doesn't work

Discussion in 'MacBook Pro' started by kousha, Jan 7, 2014.

  1. kousha macrumors newbie

    Joined:
    Nov 18, 2013
    #1
    Hi there,

    My Mac started to act weird. First it was slow. I ran disk utility and it said my hard drive was faulty. So I ordered a new hard drive. Then the screen would freeze. Turning it on would get stuck on the grey screen. Recovery would turn into a blue screen and get stuck.

    So I ran the AHT (Command + D). It said my ram was broken (4MEM error). So I also bought new ram. I changed both the ram and the HD and ran the AHT again. This time, all went well and no errors were given (I did the long test).

    I started the internet recovery (command + option + r). It would load the files, restart and get stuck on the grey screen again.... What's going on? What can I do?

    Thanka
     
  2. kousha thread starter macrumors newbie

    Joined:
    Nov 18, 2013
    #2
    Okay so I got to the recovery: I held option when the computer restarted and it worked. It loads Lion. But now it gives me an error saying there was an error while starting the installation.

    I looked online that this is a problem with lion and that the installation file has to be on a different HD. What do I do? I don't have another HD!!! My other HD is fried...
     
  3. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #3
    Make a bootable USB and then run the Lion installer from there....
     

Share This Page