Internet recovery downloads OS X 10.11.2

Discussion in 'OS X El Capitan (10.11)' started by fimeral, Oct 28, 2015.

  1. fimeral macrumors newbie

    Joined:
    Oct 28, 2015
    #1
    Earlier today, I have reinstalled the os x el capitan and internet recovery downloaded OS X 10.11.2
    Apple seeded the first beta of OS X 10.11.2 update to developers just today. Trouble is that neither I am developer nor I have any developer account

    how could this be possible?

    Screen Shot 2015-10-28 at 22.39.31.png
     
  2. tywebb13 macrumors 68000

    Joined:
    Apr 21, 2012
    #2
    WOW!

    Build 15C30 is even a higher build than the developer seed!

    It hasn't even been released to developers.

    Sounds like an engineering seed may have accidently been put onto the wrong directory on apple's internet recovery server.
     
  3. SoyCapitanSoyCapitan macrumors 68040

    SoyCapitanSoyCapitan

    Joined:
    Jul 4, 2015
  4. davidlv macrumors 65816

    Joined:
    Apr 5, 2009
    Location:
    Kyoto, Japan
    #4
    Just did a Command + r boot, into the recovery partition, and selected the Re-install OS X option. Result was the same as posted by the OP, Build 15C30. A CCC clone over an 10.11.1 disk showed about 23GB of writes! Lots of different files or dates. And yes it does fell snapp... oh forget it.
     
  5. paulCC macrumors member

    Joined:
    Nov 2, 2012
    #5
    yes, I just tried the Recovery Internet reinstallation, and I am now running 10.11.2.

    One of the 2 bugs I experienced is fixed - the Preview now opens large JPG files correctly, no more green rectangles in the screen.....
     
  6. Peter118 macrumors newbie

    Joined:
    Aug 19, 2015
    #6
    Same here. Recovery boot, clean install. Version 10.11.2. Where does this suddenly come from?
     
  7. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #7
    This is truly odd. So none of you folks were in any of the dev. or beta programs at all?
     
  8. paulCC macrumors member

    Joined:
    Nov 2, 2012
    #8
    I am not in the Apple Developer group, never paid the fee.....I am using Xcode sporadically, but that surely should be no reason Apple would choose me to be a beta guinea pig, especially without asking me....

    The second bug that bit me in El Capitan - a simple SATA to USB3 adapter now working - is still not fixed.
     
  9. Erdbeertorte, Oct 29, 2015
    Last edited: Oct 29, 2015

    Erdbeertorte macrumors demi-goddess

    Erdbeertorte

    Joined:
    May 20, 2015
    Location:
    Castle Grayskull, Eternia
    #9
    I had the developer beta of 10.11.2 installed until I did an Internet recovery yesterday or the day before, but it got back to 10.11.1 after that.

    Now I am installing the update from the AppStore. I am curious if I get the new build number too...

    Edit: 15C27e :(

    I could try a reinstallation now...

    The installation protocol is showing 10.11.1 15B42 while downloading components. I think it will take me back. :(

    But that is the normal way. As long there is no full installer, the version that will be installed from the recovery partition does not change and internet recovery should normally never provide a beta.


    Perhaps they just forgot to put a letter behind the 15C30 build and it was recognized as the final version.
     
  10. Donfor39, Oct 29, 2015
    Last edited: Oct 29, 2015

    Donfor39 macrumors 6502a

    Donfor39

    Joined:
    Jul 26, 2012
    Location:
    Lanarkshire Scotland
    #10
    10.11.2 is available..downloading...1.34gb 5mins..15C27e
     
  11. pat500000 macrumors 604

    pat500000

    Joined:
    Jun 3, 2015
    #11
    I would stay on that...please investigate more on differences.
     
  12. raab macrumors member

    Joined:
    Jul 23, 2010
    #12
    Coincidentally I did a recovery last night to install over the top of, looks like I got 10.11.2 Build 15C30 as well
     
  13. Peter118 macrumors newbie

    Joined:
    Aug 19, 2015
    #13
    No, very strange indeed
     

Share This Page