Internet runs slow on Mac

Discussion in 'Mac Basics and Help' started by Ansis42, Jun 28, 2012.

  1. Ansis42 macrumors newbie

    Joined:
    Jun 26, 2012
    #1
    Hello everyone,

    My girlfriend has a Macbook Pro, running an older OS (SnowLeapord I think?). She's having some weird issues on the internet. The internet generally runs really slow. You can especially notice this on sites like YouTube, and similar sites.
    Here's where things get weird:
    1) The internet (and YouTube) runs just fine on my Windows7 laptop
    2) When she accesses my neighbors Wi-Fi (which I know is illegal), her internet runs great! YouTube is as fast as ever!
    3) When she accesses the internet at her parents house, her internet runs great! YouTube is as fast as ever!
    So, I've narrowed it down to some setting I have on my network (on the back end). It must not be some setting on her computer, and it must not be something "wrong" with my network, since my PC runs just fine. Does this raise any red flags for anybody? Thank you very much.
     
  2. Lbj6 macrumors newbie

    Joined:
    Aug 26, 2012
    #2
    My MacBook Pro is doing this now! It worked fine for the first 6 months. Perfect in fact. Last week it is slow to the point of unusable. Every other computer on the network works fine. Any help anyone? I've tried many fixes. My gut feeling is a unique problem between my computer and the modem, but I'm not a technician.
     
  3. thasan macrumors 6502a

    Joined:
    Oct 19, 2007
    Location:
    uk
    #3
    i had problem in mine too today. but it was down to images in amazon and fb and taking ages loading some pages. i had the same problem in my windows partition and in all the browsers.
    it was probably down to server cause now things are a bit better.
    i think some people suggests to disable DNS..but i havent tried it.
     

Share This Page