Internet sharing broken in Mountain Lion?

A

AhmedFaisal

Guest
Original poster
On my MacBook Air after upgrading to Mountain Lion I can no longer share my internet connection (USB Ethernet) via WiFi. The moment I turn it on, neither the MacBook Air itself or any of the devices connecting through the wireless connection can access the internet at all. Worked fine before on Lion so I am wondering if there is a bug....
 

omgo

macrumors newbie
Oct 23, 2010
9
0
I think it is broken indeed. I have to unplug ethernet, turn off wifi, turn off wifi sharing and then turn everything on, do it twice and then maybe my ipod touch and another macbook air running lion can connect. or sometimes there seems to be a connection, but DNS is not working..
its a mess:((

edit: on the other hand, there is finally WPA option in Mountain Lion internet sharing.. so far there was only WEP
 

Wordman

macrumors member
Jan 14, 2010
60
1
Fixed

I had the same problem.

After scouting around some forums, I activated the wifi monitor that's new to Mountain Lion. Not sure if it's a coincidence or not, but my Internet Sharing seems to now be working on one click of my wifi icon.

Previously, I had to switch it off and on again every time I booted up my iMac.

Curiously, the wifi icon has now changed. In Snow Leopard, it was just the 'fan' icon in black. Now it's grey with a white arrow in it.
 

CHFeatherstone

macrumors newbie
Nov 1, 2012
1
0
Figured It Out

Make sure to manually assign the DNS of whatever you are connecting to the internet with (in my case, the Clear modem) via ethernet is the same as the DNS in whatever device wants to share the connection.

On the Mac:
System Preferences > Network > Ethernet > Advanced > DNS

On my iPhone:
Settings > Wi-Fi > [Name of Shared Network] > DNS

Make sure they match. Mountain Lion 10.8.2 does not do this. For example, sharing told my iPhone the DNS server was 192.168.2.1, which is not the DNS address of the Clear modem. So, I manually changed it on the iPhone. It appears, so far, that so long as the iPhone remembers the shared network, it remembers the right DNS address. But I had it forget the network, and it proceeded to forget the right DNS address.

I'm hoping this is a bug, and not a feature. ;)

CHF
 

nefa

macrumors member
Aug 16, 2011
39
0
Make sure to manually assign the DNS of whatever you are connecting to the internet with (in my case, the Clear modem) via ethernet is the same as the DNS in whatever device wants to share the connection.

On the Mac:
System Preferences > Network > Ethernet > Advanced > DNS

On my iPhone:
Settings > Wi-Fi > [Name of Shared Network] > DNS

Make sure they match. Mountain Lion 10.8.2 does not do this. For example, sharing told my iPhone the DNS server was 192.168.2.1, which is not the DNS address of the Clear modem. So, I manually changed it on the iPhone. It appears, so far, that so long as the iPhone remembers the shared network, it remembers the right DNS address. But I had it forget the network, and it proceeded to forget the right DNS address.

I'm hoping this is a bug, and not a feature. ;)

CHF
Wow, thanks so much, you fixed it for me! I had to restart the sharing all the time and now it seems to work!