Internet sharing bug

Discussion in 'Mac OS X Lion (10.7)' started by boilingpoint, Jun 7, 2011.

  1. boilingpoint, Jun 7, 2011
    Last edited: Jun 7, 2011

    boilingpoint macrumors member

    May 18, 2011
    Once configuring internet sharing, I know the target network adapter for internet sharing will be configured to IP Address. However like in earlier versions of Mac OS X and all other computer OS, user can change it to the other IP address range (e.g., ...). It is ok to set the gateway address to and the dns address to on the internet shared computer.

    However, if I change the IP address range, internet sharing does not work any more. Internet sharing works only using IP address.

    It is obviously a bug. It was in DP3 and still remains in DP4. :(
  2. boilingpoint thread starter macrumors member

    May 18, 2011
    This bug still remains in GM. :(

    Apple, come on~~~~
  3. boilingpoint, Aug 22, 2011
    Last edited: Aug 22, 2011

    boilingpoint thread starter macrumors member

    May 18, 2011
    What I really want is about SharingNetworkNumberStart. When I view the InternetSharing executable binary, it contains "SharingNetworkNumberStart" string. But it does not work at all. This problem still remains in 10.7.1.

    InternetSharing(8)                       BSD System Manager's Manual                      InternetSharing(8)
         InternetSharing -- simple NAT/router configuration daemon
         InternetSharing -d
         InternetSharing is the back-end for the Internet Sharing feature.  It is responsible for configuring
         the network interfaces, the DHCP server bootpd(8), the network address translation daemon natd(8), and
         the Internet domain name server named(8).  named(8) is run in caching-only mode and allows the DHCP
         server to always offer the same DNS server address to the DHCP clients, regardless of the value of the
         actual DNS server addresses.
         The single command line option -d places additional debugging information to stdout/stderr.
         InternetSharing is launched by launchd(8) both at start-up and when the user turns Internet Sharing on
         in the Sharing preferences pane.
         By default, InternetSharing configures the IP addresses for non-AirPort interfaces starting at, walking up by one class C network (subnet mask for each subsequent inter-face interface
         face i.e.,,, and so on.  The AirPort interface by default is
         InternetSharing reads the property list stored in the /Library/Preferences/System-Configuration. /Library/Preferences/SystemConfiguration.
         Details of the are subject to change and are not completely documented here.  The
         plist is a contract between the Sharing preferences pane and InternetSharing. Any details provided here
         are for informational purposes only.
         The plist is a dictionary with a single sub-dictionary called NAT containing properties to control
         which interfaces to use and other settings.  It may also have a sub-dictionary called AirPort that is
         used to configure the AirPort interface when it is put into access point mode.
        [B] One property worth mentioning is SharingNetworkNumberStart.  This property controls the behavior of
         InternetSharing when it configures IP addresses for the local interfaces.  The property is encoded as a
         string containing the dotted decimal network IP address, assumed to be a class C network.  For example:
         If the SharingNetworkNumberStart appears directly in the NAT dictionary, it controls the starting IP[/B]
         address chosen for the non-AirPort interfaces.  If the property appears within the AirPort sub-dictio-nary, sub-dictionary,
         nary, it controls the IP address assigned to the AirPort interface.
         The purpose of the property is to allow the user to avoid address collisions with existing NAT'd net-works. networks.
  4. laurenr macrumors 6502a


    Jan 9, 2008
    I am so pleased I am not the only one having Internet sharing problems. On my Mac Pro, I am unable to get it working at all. System Prefs will allow all the steps to start the process, but no other devices can see the network. The funny thing is, I can set it up just fine on my Husband's Macbook Air.
  5. playmakerx macrumors member

    Jun 11, 2011
    Similar problem here. In my case, there is simply no sharing connection established though I finished all the process necessary, which means, the wifi icon on the menu bar is grey without that arrow meaning internet sharing.:mad:Never had this problem before.
  6. hibernian56 macrumors newbie

    Jul 18, 2008
    Its March already and no fix.

    Come on Apple, wake up and fix this.

    We use a 3G dongle for our internet at home.

    Nobody has access to the internet because of this. Thats two Mac Mini's, a Macbook Pro and my xBox.

    "It just works" doesn't it.
  7. tomhouweling macrumors newbie

    Mar 13, 2012
    Since I ran also into the frustrating problem that in Lion


    is not working anymore.

    I worked around the prioblem by patching the binary:

    Get a hexeditor such as "hexfiend"

    Copy /usr/libexec/InternetSharing somewhere.

    Open the file and search for 10.0.2 and replace with your choice of network. ( I use 10.0.3 )

    Copy the patched InternetSharing binary back to /usr/libexec/InternetSharing and restart Internet Sharing.

    This works for me until Apple fixes it.


Share This Page