Resolved Internet Sharing in Lion?

Discussion in 'Mac OS X Lion (10.7)' started by swedefish, Jul 20, 2011.

  1. swedefish, Jul 20, 2011
    Last edited: Jul 21, 2011

    swedefish macrumors 6502

    Joined:
    Feb 12, 2008
    #1
    I can't seem to get internet sharing to work in Lion. If anyone knows of a fix or any official info re internet sharing in 10.7, please post. Many thanks, k/x
     
  2. Aerizon macrumors newbie

    Joined:
    Jun 2, 2010
    #2
    can't get it to work as well. i've tried all of the options but my iPad just can't detect the network.Broken?
     
  3. ConnorCG macrumors member

    Joined:
    Jan 18, 2011
    #3
    Is it possible that you are trying to push your ethernet connection to AirPort instead of Wi-Fi? I share my Wi-Fi connection through my ethernet, and Internet Sharing left settings as AirPort -> Ethernet, but now in Lion it has to be Wi-Fi -> Ethernet for my settings.
    [​IMG]

    You would have opposite settings.
     
  4. gazrsvr macrumors newbie

    Joined:
    Jul 21, 2011
    #4
    I had the same problem and found that I had to set up the security password again in system preferences/sharing. Click on Wi-Fi options at the bottom of the Sharing preferences and select the level of security you want. Then enter your password and click OK. You might find that you will have to re-enter the password on your iPad/iPhone even if it is the same one that you used previously.
     
  5. swedefish thread starter macrumors 6502

    Joined:
    Feb 12, 2008
    #5
    Sorry, but I'm not really sure what you mean. Airport isn't even an option in Lion.

    This worked. Thanks a bunch!
     
  6. jw2002, Jul 21, 2011
    Last edited: Jul 21, 2011

    jw2002 macrumors 6502

    Joined:
    Feb 23, 2008
    #6
    Same problem here. I have always successfully shared my connection from wifi to computers using ethernet (actually its a voyage dongle on the other end) in Snow Leopard. Now it doesn't work in Lion. Here's what the console says:

    Code:
    7/21/11 5:32:11.000 PM kernel: Ethernet [nvenet]: Link up on en0, 100-Megabit, Full-duplex, Symmetric flow-control, Debug [796d,0000,0de1,0005,45e1,0000]
    7/21/11 5:32:11.000 PM kernel: 05f5e100  00500026  NVEthernet::setLinkStatus - Active
    7/21/11 5:32:12.600 PM ntpd: bind(33) AF_INET6 fe80::223:dfff:fe9d:6656%4#123 flags 0x11 failed: Can't assign requested address
    7/21/11 5:32:12.600 PM ntpd: unable to create socket on en0 (12) for fe80::223:dfff:fe9d:6656#123
    7/21/11 5:32:26.582 PM UserEventAgent: ServermgrdRegistration cannot load config data
    7/21/11 5:32:26.582 PM UserEventAgent: ServermgrdRegistration oldConfig is nil during net changed notification
    
    Edit: Here's an update. It was the same problem as mentioned above. The sharing was still using the old "airport" instead of the new "wifi". Going in and changing to wifi fixed it.
     
  7. kodilane, Jul 23, 2011
    Last edited: Jul 23, 2011

    kodilane macrumors newbie

    Joined:
    Mar 29, 2009
    #7
    Internet Sharing from Airport to Ethernet. Lion


    In snow leopard i would use the settings Share your connection from : Airport
    to computers using Ethernet.

    After the update to Lion i found that these setting still said this, however it didn't work.

    When i clicked the drop down to share connection now Wi-Fi was among the list, i selected wifi and then share to ethernet, and the settings still didn't work.

    now when i click the drop down box, the airport has disappeared.
    I am trying to share my internet from WIfi to the Ethernet that goes to my Xbox 360.

    So i have my ethernet settings configured. and it says connected, but the actual internet connection is still sharing to airport, even after i change it... Some problem in the code here. anyone know a fix?


    I switched to share from WIFI to computers using Ethernet, and my ethernet detects that its connected but there is no internet connection, it says can't resolve DNS. So the internet is not actually being shared.


    FIX. Okay the solution was to change WIFI TO Share with computers using Ethernet, but in LION we no longer need to manually configure the Ethernet Connection. I Selected Using DHCP, and then on my xbox360 chose automatic settings for IP and DNS, and it worked.!
     
  8. kojip123 macrumors newbie

    Joined:
    Jul 25, 2011
    #8
    in Lion, use simple computer name. i.e: MBA, instead of Somebody's Macbook air. It worked for me
     
  9. Mullum05 macrumors newbie

    Joined:
    Sep 22, 2011
    #9
    Does anyone know how many connections you can make with Sharing Internet?
     
  10. 187 macrumors newbie

    Joined:
    Sep 12, 2011
    #10
    That worked for me. I've been trying to figure this out for weeks! Thanks so much!

    Amazingly simple solution. Brings me back to my enduring preference for more traditional digital naming conventions.
     
  11. lopoz macrumors regular

    Joined:
    May 10, 2005
  12. BostonMerlin macrumors newbie

    Joined:
    Jun 29, 2007
    #12
    i have no problem sharing but find that just about every time i reboot my macbook air, the "share your connection from" drop down selects "nothing". I have to select my usb ethernet (which is always plugged into the airs usb port).

    would also like to know how many connections you can share. Right now, my air is sharing to an android tablet, android phone, iPhone 4s, iPad2 and win phone 7.
     
  13. bluepolo, Mar 6, 2012
    Last edited: Mar 6, 2012

    bluepolo macrumors newbie

    Joined:
    Nov 3, 2008
    #13
    I found that I had to create a wireless network first - here's some instructions

    http://www.hutsby.net/2009/03/share-ethernet-internet-connection-in.html

    I also notice that if you go to the Network control panel, it doesn't show the IP address correctly of the wifi card, it only shows the self-assigned address.

    If its working correctly, if you do "ifconfig" from terminal, you should see the second address <10.0.2.1>:

    $ ifconfig
    en1: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    inet 10.0.2.1 netmask 0xffffff00 broadcast 10.0.2.255
    inet 169.254.234.139 netmask 0xffff0000 broadcast 169.254.255.255
    media: autoselect
    status: active
     
  14. mladin macrumors newbie

    Joined:
    Mar 29, 2012
    #14
    only google , yahoo messenger and unread.com works

    hello,

    i am trying desperately to figure out why i can´t share internet over my internal wifi card mac osx lion on my iPhone or pc,
    somehow there are only some sites connecting: google whit all search results, onread.com.... sometimes yahoo messenger app,.. but nothing else is opening

    who has an idea??
     
  15. wolfmurphy macrumors newbie

    Joined:
    May 7, 2012
    Location:
    San Pablo, Ca
    #15
    Sharing Ethernet to WiFi worked when I changed the channel

    I tried many of the suggestions. What worked for me was changing the WiFi channel from 11 to 6. Then when I shared I got the correct arrow in my status bar and more important, was able to get internet on my iPad.

    It still seems like superstitious behavior rather than a rational series of steps to get sharing to function as it did in a pre-Lion world.

    ... Tom
     
  16. disbellj macrumors newbie

    Joined:
    Feb 20, 2015
    #16
    Had To Fix Network Preferences First

    I had Network Preferences set to Automatic, which let me connect to internet through automatically detected WiFi. But in Sharing Preferences, Internet Sharing was unchecked, grayed out / greyed out, and there were no options under WiFi which was also grayed out / greyed out.

    When I changed Network Preferences to Wifi, and it showed Wifi and Ethernet both unconnected. After Wifi connected and got an IP address, I was able to go to Sharing Preferences and place a checkmark next to Internet Sharing, and also Ethernet was available under Wifi and checked.

    Hope this helps someone.

    Kindest regards,

    Don
     

Share This Page