Internet Sharing On

Discussion in 'Mac Help/Tips' started by peterj1967, May 19, 2003.

  1. peterj1967 macrumors regular

    Aug 30, 2002
    There have been a number of posts about preferences not sticking, so I hope this isn't a redundant post. I couldn't find it with a search.

    I have a PM G4 with an airport extreme card, and a PB g3 with a good old airport card.

    I have internet sharing on, on my g4, works great, but internet sharing turns off if I restart or shut down. I need to turn it back on every time I turn the G4 back on.

    Is that a security feature, or a bug? Tried repairing disk permissions, but the problem stays. I am running 10.2.6 on both machines with that latest Airport updates.

    Any ideas? I can't seem to find anything.
  2. ibookin' macrumors 65816


    Jul 7, 2002
    Los Angeles, CA
    This seems to be a bug. I've never had this problem on any of my machines (iMac G4, iMac G3, iBook 800, iBook 500).
  3. 5300cs macrumors 68000


    Nov 24, 2002
    I've had the same problem on all my 10.2 machines. I haven't found a sollution either, so I just remember to turn it back on after any restarts.

    Anything on I wonder?
  4. Thom_Edwards macrumors regular

    Apr 11, 2003
    Re: Internet Sharing On

    from my experience, if a service doesn't stay on after a restart it is because of a faulty configuration or some kind of conflict. i see it sometimes when i've change the config of apache and tomcat. i usually have several services trying to use the same port.
    you don't say too much about the configuration of you internet connection and network. if you are using high-speed and a router, i would turn the dhcp server on the router off. let the dhcp server on the mac handle the ip distribution. in my eyes, having a dhcp server look to a dhcp server for ip addresses is a little redundant. other than that, all i can say is tinker. there is probably some tiny little thing that is putty a monkey wrench in your gears.
    then, of course, it could be a bug! good luck!
  5. peterj1967 thread starter macrumors regular

    Aug 30, 2002
    No Fancy Network

    Nothing fancy about the config.

    G4 is plugged into my cable modem, gets an IP with DHCP. I run WEP Enabled Internet Sharing on the G4, 128 bit, firewall is off, file sharing is on.

    G3 PB is the one and only client and when the services is running, it all works great.

    In reply to a previous post I couldn't find anything on the apple support site, but I may follow up with a post there.

    Isn't a huge problem, just one of those little annoyances that are only supposed to happen in the windows world

  6. cosmicsoftceo macrumors newbie

    Oct 11, 2002

    Go to, and search for Internet Sharing Startup. You'll find a hint for everything there. :)

    In particular, this hint tells you how.

    If you don't mind editing system files. ;)

Share This Page