Internet Sharing Painfully Slow

Discussion in 'iPhone Tips, Help and Troubleshooting' started by eco, Apr 1, 2016.

  1. eco macrumors newbie

    Aug 23, 2011
    I have used Internet Sharing from my iPhone to both my iPad Mini and my Macbook Air for several months with great success. However, it is now painfully slow using both Bluetooth and WiFi sharing.

    I get around 40 MBit/s on the phone, and less than 1 MBit/s on a connected device. This holds true for both my Mac and my iPhone (6). Connecting the phone to the computer with a cable though, everything runs smooth (no speed loss).

    I have tried the usual things, such as
    - Disconnect and reconnect all Bluetooth devices on both iPhone and iPad.
    - Turn on/off Bluetooth
    - Reset network settings

    I still haven't tried full resets of any device. I have however also tried two other iPhones (6S and 5S) connected to the iPad. Both showed similar crappy speeds when connected. I also used Internet Sharing via WiFi to a Windows computer, and that worked fine.

    Any thoughts? In desperate need of help...
  2. justinvirk macrumors newbie

    Apr 1, 2016
    Just chatted with online support. Reset network settings and works perfectly fine now. It's under Settings>General>Reset>Network Settings. Try that before heading to Genius Bar tomorrow.
  3. eco thread starter macrumors newbie

    Aug 23, 2011
    Thanks justinvirk. I have reset network settings on both devices (iPhone and iPad), with no success.

    Any other suggestions?
  4. justinvirk macrumors newbie

    Apr 1, 2016
    iOS 9 features a new Wi-Fi Assist option that basically switches to your Cellular connection automatically whenever it detects problematic WiFi connection. Toggle this option to on and then off from Settings > Cellular > Wi-Fi Assist to see if this fixes the problem. Your mileage may vary with this. You can learn more about this feature here: Why And How To Enable iOS 9 WiFi Assist Feature On iPhone.

    Use OpenDNS or Google DNS

    In certain situation when your Internet is too slow, changing your ISP fetched DNS server to an OpenDNS or Google DNS can fix that issue, just like on a computer. To do this, simply tap the ‘i’ button next to your connected WiFi network, and tap the number appearing next to DNS. Here, you can enter a Primary DNS and Secondary DNS, both separated by a comma. Once entered, simply exit settings and take Safari for a spin.

    Google DNS:,

    Disable Location Services For Wi-Fi Networking

    Some users have reported that disabling Wi-Fi Networking in Location Services has done the trick for them. To do this, launch the Settings app and navigate to Privacy > Location Services > System Services, and disable Wi-Fi Networking. Reboot your Iphone

Share This Page

3 April 1, 2016