internet sharing with ps3

Discussion in 'Console Games' started by matt3224, Jun 3, 2009.

  1. matt3224 macrumors member

    Joined:
    Jun 12, 2008
    #1
    This is driving me nuts i have phoned apple and sony both of which have been no help. Basically i would like to connect the ps3 to my mac via ethernet switch on internet sharing and set it so the mac receives the internet via airport and sends it out via ethernet. i have gone to prefs and set it up, plugged it in but it just won't work. fails on obtaining ip and when i put one in myself it fails on internet connection. please help. i dnt want the ps3 to use wireless.
     
  2. jakerules133 macrumors member

    Joined:
    Jan 8, 2009
    #2
    dude me too, i'm going ****ing crazy trying to figure this crap out for 2 hours. I've had it going before but then it just stopped working. I hate the ps3's online settings. Sony should be ashamed to even think they have the superior console with the **** that still has to be worked out.
     
  3. matt3224 thread starter macrumors member

    Joined:
    Jun 12, 2008
    #3
    sucks

    Sucks tried for a few hours yesterday, tried typing everything manually. phoned apple they said the mac is fine and to phone sony, phoned sony talked to some complete wang who said he new what the problem was at first then turned to saying that they tried it and it just didnt work. i told him the 360, pc, laptop all work with it but not the ps3, he said it doesnt work. then i said it had been working and he said hed check with nother member of staff and then came back saying it shudnt have been working and it wont work. its stupid surely its just like plugging it in a router ? :mad:
     
  4. jamesschmidtke macrumors regular

    Joined:
    Mar 15, 2008
    #4
    hey guys, first let me say I understand what you're going through. here is the solution that worked for me and many others. Let me say though it really only works to surf the internet, download updated, games , etc, doesn't work well or really at all with online gaming. So after a year of ps3 ownership I bought the new time capsule and I seriously sugeest you do that or get airport extreme, your sanity is worth more. But if you're cool with the above this really does work or at least it will until snow kitty....



    thanks to jtrenda33 for his efforts as this solution may be the right one for some

    I finally got my PS3 to connect to the internet using the built-in airport card. Here is what I did.

    Turn on Internet Sharing. If you don't know how to do that then ask me and I will walk you through that as well.
    Open Terminal and type this exactly as shown:

    cp /etc/bootpd.plist /tmp/bootpd.plist

    Hit the Return key. It may seem as though nothing has happened. That's okay.

    Turn Internet Sharing off.

    Go back to the Terminal window and type:

    open -e /tmp/bootpd.plist

    Hit the Return key. A file will open in TextEdit. Locate this section of the file, near the end:

    <key>reply_threshold_seconds</key>
    <integer>4</integer>

    Change 4 to 0 and then hit Command+S to save the file.

    Go back to the Terminal Window and type:

    sudo cp /tmp/bootpd.plist /etc

    You will need to know the administrator password. If you do not have one set up, then you might need to set one up first. You will be warned that this could be dangerous. I don't know what any of this is doing, but it worked. So if it messed up my computer, I can't tell because everything seems to be working perfectly.

    Okay. After you enter the password, hit the Return key.

    Turn Internet Sharing back on.

    Now. Go over to your PS3 and set up a wireless connection the "easy" way. It said it was checking some network configurations or something like that and then it brought me to the SSID screen. I chose Manual and selected my access point that was already in there from before and then typed in my WEP password. Then I moved on and let it do everything automatically and it worked! Try it out. Let me know if this helps or if I need to clarify something that didn't make sense.
     
  5. mindspin macrumors newbie

    Joined:
    Dec 9, 2010
    #5

    As far as I can tell, this worked for me. My ps3 was acting weird at first and it even erased my stats on COD black ops but looks like they somehow came back. Seems to have a stronger connection with the ethernet running from my mac which is getting wireless from router upstairs
     
  6. miguueeel macrumors member

    Joined:
    Dec 8, 2010
    Location:
    Chicago
    #6
    I use to be able to do this so simply in my old PC !.
     
  7. Rstern macrumors newbie

    Joined:
    Jan 21, 2011
    #7
    PS3 to Imac Airport

    Simple

    1.PS3 IP address=Internet Airport IP Address found by going to Internet Sharing(turn off internet sharing) select Airport (not ethernet) and click Advanced Settings. Airport IP address is located here, with Subnet Mask and Router info. This information is what you "manually enter into the PS3, (note when selecting a WEP Key with non apple computers such as a PS3 you have to choose a 5 character ASCII on your main IMAC Airport wireless network) enter the 5 WEP Key password, and continue to manually enter the IP Address above+subnet+router #,....last is locating your Primary/Secondary DNS (easy located on main IMAC "Ethernet connection" found under system preferences/network/ethernet/DNS primary followed by secondary. last step on PS3 finish info by selecting MTU "auto", Proxy "do not use", UPnP "disable", then watch the majic..hopes this helps all the confusion seen with PS3 and Macs.
     
  8. sugarcanesavage macrumors newbie

    Joined:
    Feb 15, 2011
    #8
    You are my hero

    Started working right away


     
  9. sevven macrumors newbie

    Joined:
    Feb 17, 2011
    #9
    worked great! thanks a lot!


     
  10. StruckANerve macrumors 6502

    Joined:
    Dec 31, 2008
    Location:
    Rio Rancho, NM
    #10
    I don't understand why you would go through all this trouble when the PS3 has built in wireless? You're connection is still only as stable as the wireless connection between your Mac and the router.
     
  11. macbookproi7 macrumors newbie

    macbookproi7

    Joined:
    Feb 22, 2011
    Location:
    Brisbane, Australia.
    #11
    Thanks a lot for this thread. I too have no idea what it actually did to my computer though so feel a little stupid doing it, but really wanted to get online on my ps3.

    I thought I'd also mention, the first time I tried I didn't do as you suggest and make sure my Login had a password, and when it asked for one I left it blank and hit enter and it said INCORRECT, so I had to do it again. And even when I'd gone through it that time my PS3 didn't connect.

    So I restarted the computer and PS3 and did it all again in Terminal (this time with a password) and it came up on my TV screen above the PS3 XMB something about a connection error and gave me code, I ignored that and tried to connect and it worked like a charm.

    Thanks again.
    Cheers
     
  12. macbookproi7 macrumors newbie

    macbookproi7

    Joined:
    Feb 22, 2011
    Location:
    Brisbane, Australia.
    #12
    The reason I'm doing this by the way, is because I'm not at home and I'm living in a flat... so I am using a wireless USB modem into my laptop and sharing via airport. Not a conventional one hooked up to a phone line. So my computer then becomes the base station for my iPhone, iPad and now Playstation while I'm on the net on my MBP
     
  13. d8blitzkrieg macrumors newbie

    Joined:
    Mar 3, 2011
    #13
    Does this work with Snow Leopard as well??? This damn thing is driving me absolutely insane. I'm doing exactly as the instructions say to do and it's telling me that the file doesn't exist. Is there a specific way to do it for the new Mac OS? Please advise asap, I have no more patience for this. :/
     
  14. macbookproi7 macrumors newbie

    macbookproi7

    Joined:
    Feb 22, 2011
    Location:
    Brisbane, Australia.
    #14
    I have Snow Leopard 10.6.6 and it works fine for me. Be sure to copy and paste exactly what 'sevven' said, don't just type it incase you are making a mistake. Make sure you start from scratch if it hasn't work (ensure you have a Adminstrator password for your account).

    Disconnect the net, reconnect.. ensure sharing is on. After logging out and in on your playstation.. do the first command line... then turn off sharing. do the rest... like it says change the 4 to 0 and hit Command - S, you will see the File in the menu bar up the top highlight because command S selects the save option in File... then hit enter. Copy and Paste the next command into the terminal.. turn sharing BACK on, and then go back to your playstation, connection settings.. Easy> wireless> scan for your computer... select it> choose WEP...
    (make sure on your mac the network you have made you have chosen the WEP setting and make your password a five letter password... I made mine ascii because that is the type of password it is and so it is easy to remember)

    type your password in and go next, then next>next etc right untill it finnishes... then try your connection and it should work. I don't know if it makes a difference but after I have done everything before I try and make my connection I close the Terminal and sharing etc.. then try it.

    If it still doesn't work, turn off your playstation, turn off sharing, then turn your playstation back on and try it again, Since doing it the first time I have reformatted my mac and had to do it again each time ... even though the number stayed at 0 I still went through that step and saved it as 0 again.

    You'l get it to work.
     
  15. Petran1 macrumors newbie

    Joined:
    Apr 15, 2011
    #15
    Works... but not for VPN?

    My MAC is connected to the internet via WiFi and when I connect my ps3 (and ATV1 for that matter) to my MAC via ethernet, the ps3 is connected through my MAC and that works fine.

    But... when I connect my MAC through a VPN (Witopia), it does no longer work! I tried changing the internet sharing settings on my MAC to 'from VPN (PPTP)' (instead of Airport) but still no joy.

    Any thoughts?
     
  16. toobigtofly22 macrumors newbie

    Joined:
    Nov 1, 2007
    #16
    I have the same issue.... I can connect to my mac fine if I'm not on a VPN, but as soon as I start the VPN on my mac, my PS3 drops the internet connection.
     
  17. ImAFunnyGuyPS3 macrumors newbie

    Joined:
    May 30, 2011
    #17
    Dear God why isn't it working now.

    So I have figured this out three times now and it for some reason it isn't working now. Do I have to change IP addresses everytime? See backstory below.

    Initially shared my USB modem through my MAC into my PS3 via Ethernet. Worked great for months no problem, turn it on it worked. Then I fried my hard drive with a rare earth magnet I know I'm an idiot. Same MAC osx 10.4.11 with a new hard drive. At first I tried to use the same settings and didn't work but then I realized I had my ports turned off. Turned my ports back on worked fine. Came back a couple days later PS3 wouldn't connect. I had used basically the same settings that MacRumor user Winni defined in his thread and it worked. Now I get back on today the same thing no internet connection. With PS3 getting hacked have they removed this ability? I'm lost please help.
     
  18. irrationalpi macrumors newbie

    Joined:
    Jun 1, 2011
    #18
    I'm running Leopard 10.5.8 and it doesn't work!
    I've copied and pasted it exactly in the Terminal as what you've said, the: cp /etc/bootpd.plist /tmp/bootpd.plist
    But I'm still getting message "no such file or directory"... :confused:
    Help me please!! :(
     
  19. maamepanyin macrumors newbie

    Joined:
    Jun 9, 2011
    Location:
    Cape Town
    #19
    Airport not working after trying to connect PS3

    Dear All,
    I need some serious step-by-step technical advice. I was trying to connect my PS3 wirelessly via internet sharing to my 15” macbook pro OS X 10.67. well I could not get the PS3 to connect after several attempts. The ps3 just would not be able to get an IP. I googled up this problem and came up with the solution below which I applied. Afterwards the PS3 connected and was able to get an IP but still could not go online. After several attempts I finally gave up on it.

    Now the problem is that I came into the office this morning and my macbook will not connect to the office wireless network. It would connect but was unable to get an IP address. After several attempts it got an IP but would not browse. Tried several browsers, safari and firefox would just not load any pages. I went back and followed the instructions changing the integer 0 back to 4. I restarted the laptop but the problem persists. Currently I am using a cable at the office to go online. Even with the cable firefox is working fine but safari still refuses to connect. I need a way to undo all the changes that occurred and get my laptop back connecting without trouble as I will not have access to the cable connection all the time and I do not know if this will be an issue on other wireless connection.

    I use a USB modem Internet connection at home which also worked fine after the changes. I need clear step by step advice as i am a novice at all this. some additional information the office internet uses a proxy and a password.

    Thank you all so much for the support.

    "Turn on Internet Sharing. If you don't know how to do that then ask me and I will walk you through that as well.
    Open Terminal and type this exactly as shown:

    cp /etc/bootpd.plist /tmp/bootpd.plist

    Hit the Return key. It may seem as though nothing has happened. That's okay.

    Turn Internet Sharing off.

    Go back to the Terminal window and type:

    open -e /tmp/bootpd.plist

    Hit the Return key. A file will open in TextEdit. Locate this section of the file, near the end:

    <key>reply_threshold_seconds</key>
    <integer>4</integer>

    Change 4 to 0 and then hit Command+S to save the file.

    Go back to the Terminal Window and type:

    sudo cp /tmp/bootpd.plist /etc

    You will need to know the administrator password. If you do not have one set up, then you might need to set one up first. You will be warned that this could be dangerous. I don't know what any of this is doing, but it worked. So if it messed up my computer, I can't tell because everything seems to be working perfectly.

    Okay. After you enter the password, hit the Return key.

    Turn Internet Sharing back on.

    Now. Go over to your PS3 and set up a wireless connection the "easy" way. It said it was checking some network configurations or something like that and then it brought me to the SSID screen. I chose Manual and selected my access point that was already in there from before and then typed in my WEP password. Then I moved on and let it do everything automatically and it worked! Try it out. Let me know if this helps or if I need to clarify something that didn't make sense."
     
  20. macbookproi7 macrumors newbie

    macbookproi7

    Joined:
    Feb 22, 2011
    Location:
    Brisbane, Australia.
    #20
    Hi mate, looks like you're having some trouble, I know what thats like and it's pretty frustrating,

    I am not entirely sure but I will try to help...

    My advice would be to make sure you go back and ensure you change everything back to the way it was before (I know you said you did but try again) remember making changes to things like that can cause problems if you don 't know what you're doing.

    Then contact your internet service provider (don't tell them you made changes because they will more then likely say it's your fault deal with it and not help you as that is easier then being friendly and helping you) but they should give you a intranet address to go to the website for your particular modem and devices etc, and in there they should give you directions on reseting firmware or perhaps upgrading/downloading new firmware for your modem/device.

    After they've guided you through all this process and got you to do all the turn off restarts etc hopefully you will sort out your problem, Some pretty obvious advice would be to make sure you sort out your connection issues and KNOW what went wrong before trying to connect your ps3 again.
    Note when I did the hole terminal thing with sharing with ps3 I did it wirelessly and didn't use any cables.
    Hope that helps in some way, good luck,
     
  21. Keopx macrumors newbie

    Joined:
    Nov 18, 2007
    #21
    Try this solution!

    For anyone trying to share wireless internet connection to a PS3 with a mac airport, try the solution by dan76n located here. It worked right away for me with my 2007 Macbook Pro.
     

Share This Page