Internet Sharing won't work on Tiger Server 10.4

Discussion in 'Mac OS X Server, Xserve, and Networking' started by nforrester, Apr 15, 2010.

  1. nforrester macrumors newbie

    Apr 15, 2010
    I'm having major problems trying to configure Internet Sharing on my G4 Mac Mini. Any help would be much appreciated.

    The configuration is as follows: Mac Mini G4 running Tiger Server - 10.4
    I'm using Airport to connect to a private Wi-Fi network and want to share this connection through Ethernet. I have a switch connected to the Mac Mini, a Powermac G5 and MacBook. DHCP and File Sharing is working fine, however the Mini won't share the Airport Internet connection.

    Airport IP addresses on the Mac Mini are as follows:
    Router IP: - (can't change this - as I don't have access to ADSL router setup)
    Mac Mini IP: - (this is dynamic but its usually assigned this IP)

    Ethernet IP addresses as follows:
    Router IP: (note I don't have a "router" connected as such, just a switch)
    G5 IP: (dynamic - with static mapping)
    MacBook: (dynamic - with static mapping)

    I have tried the following:

    a) Tiger Server Gateway setup assistant - didn't work.
    b) The "NATural" setup assistant from - didn't work (have experimented with various settings to no avail)
    c) "IPNetShareX" from - didn't work.
    d) Tricking Tiger Server Sharing Control Panel to display "Internet Sharing" options by removing "ServerVersion.plist" from Lib/CoreServices folder - thereby allowing me to switch on "Internet Sharing" as is possible in OS 10.4 (non server version) - didn't work
    e) 2 complete system reinstalls - didn't work

    Interesting to note that from the Terminal on the G5 I can ping -,, but NOT - its getting stuck here. Also note that on my G5 I had Internet Sharing working fine sharing its Wi-Fi card through Ethernet.

    The Mac Mini won't and I can't understand why. Note again that AFP File Sharing is working fine, so I'm thinking its a DNS problem. With this in mind I used the "Server Admin" to specify ISP DNS's in the DHCP setup panel - again this didn't work. Any suggestions would be much appreciated.

    Many thanks,

Share This Page