Internet Sharing

Discussion in 'macOS' started by EdDean67, Sep 2, 2009.

  1. EdDean67 macrumors newbie

    Aug 5, 2006
    Since I have installed Snow Leopard I can't use the function in internet sharing that allows you to share your connection from ethernet to computers using Airport. Has anyone else had this problem? Anybody have ideas for a fix?
  2. macgruder macrumors 6502

    Oct 29, 2007
  3. EdDean67 thread starter macrumors newbie

    Aug 5, 2006
  4. calderone macrumors 68040


    Aug 28, 2009
    What does "can't use it" mean?

    Can even set it up for use?
    Can set it up but it doesn't work?
    Option grayed out?

    You need to be more specific.

    P.S. Try this: sudo launchctl unload -w /System/Library/LaunchDaemons/
  5. macgruder macrumors 6502

    Oct 29, 2007
    From what I gather people who've in the past had internet sharing working on Leopard are no longer able to get it to work in Snow Leopard with the same settings.

    What seems to happen is that the 'base' computer can set up to do the sharing fine but the the connecting computer keeps dropping the connection.

    My hunch was that all the issue is different it may be a similar thing to the above problem certain users got with 10.5.8 regarding "802.1X being active". Perhaps a similar check is causing the connection to shut off.

    (I haven't installed SN yet because of this very problem - I'm hoping that a solution presents itself :) )

    What happens if you run
    sudo /usr/libexec/InternetSharing -d
    in the terminal as explained in the link. What message appears? This might help track down what's causing it. And whether it can be fixed via settings or if a patch is needed.
  6. EdDean67 thread starter macrumors newbie

    Aug 5, 2006

    I see the shared ethernet in the airport of the other mac it will just not connect.
  7. EdDean67 thread starter macrumors newbie

    Aug 5, 2006
    Sorry to say but this is above my level of technical talent.
  8. macgruder macrumors 6502

    Oct 29, 2007
    Just open Applications > Utilities > Terminal

    Copy paste this:

    sudo /usr/libexec/InternetSharing -d

    Hit 'return'

    Enter your password (nothing will appear to happen as you do this).
    Hit return.
    Watch the output.
  9. EdDean67 thread starter macrumors newbie

    Aug 5, 2006
    this is the response I got. I did not have sharing turned on at the time. Should I have done that?

    InternetSharing[257]: InternetSharing starting
    /etc/bootpd.plist is empty/missing
    InternetSharing[257]: no primary service specified, exiting
  10. EdDean67 thread starter macrumors newbie

    Aug 5, 2006
    With it on this is the result.

    InternetSharing[304]: InternetSharing starting
    InternetSharing[304]: BOOTP/DHCP server already active - exiting
  11. macgruder macrumors 6502

    Oct 29, 2007
  12. macgruder macrumors 6502

    Oct 29, 2007
    Or better still, try this:

    1. Turn off internet sharing.

    2. Go into system preferences > network

    3. Click on Airport in the left hand side, then click 'advanced' on the right hand side'

    4. Click TCP/IP and turn 'Configure IPv4 to Off

    5. Click OK, then click 'Apply' in the network window.

    6. Turn Internet sharing back on.
  13. adrianyys macrumors newbie

    Sep 7, 2009
    Seems like there is two very distinct problems regarding airport and internet sharing. First one, ( which was the one I had) was I wasn't even able to create an internet sharing connection. Meaning my airport icon failed to become an arrow pointing up. Second issue is users connecting to the ad-hoc but not getting any real internet connection.

    There is a solution for the first one: I will repost here:

    Guys this solution worked for me. I will repost: by mesagsx

    I have a solution, and it worked for me today, which should make everyone here happy.

    * Under airport menu, go to "open network preferences"
    * Under "advanced" in the airport tab, click on "Require Administrator password to ... create computer-to-computer networks".
    * click OK
    * click apply
    * under airport, create a network (using some unique SSID name, like blah1)
    * under airport, disconnect from blah1
    * go back to your airport prefs again (see above)
    * uncheck that annoying option about requiring administrator password, etc...
    * click OK
    * click apply
    * go to internet sharing and do your thing like you usually did before.

    I'm guessing this is just a bug with a SETUID permission on an executable, now that this option has been added to snow leopard ... and the setting of that option, and subsequent unsetting of it is enough to get the setuid bits all correct.
  14. Pedro Borges macrumors newbie

    Sep 17, 2009
    pedro-borgess-imac:~ root# /usr/libexec/InternetSharing -d
    InternetSharing[1486]: InternetSharing starting
    /etc/bootpd.plist is empty/missing
    InternetSharing[1486]: 802.1X is active - exiting

    This seems to be the problem addressed in as mentioned before, the problem is I am sharing from AirPort to Ethernet and I need 802.1X Auth to gain internet access on AirPort. What a major screw up Apple made here. The fact that one uses 802.1X Auth to enter a wireless network shouldn't condition a service that has nothing to do with it, as far as it goes internet sharing is about translating to a range of ports whatever goes in or out of another interface, it should be transparent to how this interface is connected.

    Does anyone know a work around or have any suggestions?
  15. pinawamacuser macrumors newbie

    Sep 28, 2009
    slightly different issue

    I updated my imac from tiger to snow leopard and internet sharing quit. My issue is a little different than those above though. The list of available ports in the internet sharing dialogue box only contains firewire. The other options, airport, bluetooth etc, have dissapeared. Anyone else have this issue?
  16. odysseus macrumors member

    Mar 18, 2008
    Yes, you've hit the proverbial nail on the head. Too bad those links are no longer working, but there is indeed a conflict between 802.1X auth and Internet Sharing. Note if they both have to be on, there's no workaround, but if they don't, then clicking "disconnect" next to 802.1x in the Airport interface pane of Network will allow Internet Sharing, and conversely, if Internet Sharing has been enabled, then one has to manually click "connect" again.
  17. zar macrumors newbie

    Sep 23, 2010
    Looking for solution

    Could anyone point me in the correct direction, I am still having issues getting InternetSharing to work, I am using OS X 10.6.4.

    When I run:
    launchctl load -w /System/Library/LaunchDaemons/

    everything seems to be fine but in /var/log/system.log the following keeps looping:
    Sep 23 16:01:50 Macintosh InternetSharing[1168]: InternetSharing starting
    Sep 23 16:01:50 Macintosh InternetSharing[1168]: no primary service specified, exiting
    Sep 23 16:01:50 Macintosh[1] ( Throttling respawn: Will start in 10 seconds

    Also when I run /usr/libexec/InternetSharing -d I get:
    InternetSharing[1184]: InternetSharing starting
    /etc/bootpd.plist is empty/missing
    InternetSharing[1184]: no primary service specified, exiting

    This seems very similar to the previous post but I'm not sure if there was a solution.

    I actually don't have file /etc/bootpd.plist. I did try coping this file from /System/Library/LaunchDaemons to the /etc dir but the same errors occurred.

    Any help would be much appreciated.

Share This Page