Internet Slows to a Crawl when at Apple Discussion

Discussion in 'MacBook Pro' started by superspiffy, Aug 23, 2007.

  1. superspiffy macrumors 6502a

    Joined:
    Feb 6, 2007
    #1
    My Internet slows down to a crawl when I hit the Discussion Boards at Apple.com. And I do mean a crawl. As in it takes minutes 5 minutes to go to the Discussions selection, 5 minutes to log in my screen name, and 10-15 minutes for a post to go through! And sometimes it won't at all. I have no trouble with any other site except this one. It's not a recent thing too. It happens all the time, for as long as a couple of months now as long as I've been at home for the summer. I use both FireFox and Safari but it's the same. I'm signed up for Yahoo SBC Global DSL. I'm using a Belkin router as a WiFi repeater because my MBP can't access the Actiontech DSL gateway. There's my setup in case it helps.
     
  2. bartelby macrumors Core

    Joined:
    Jun 16, 2004
    #2
    Could it be the amount of traffic the Apple servers are dealing with rather than anything at your end?
     
  3. superspiffy thread starter macrumors 6502a

    Joined:
    Feb 6, 2007
    #3
    That's what I thought too. Until I tried my uncle's computer (a Core Duo MBP) and I didn't get any problems with the Apple Discussion Boards. It's as fast as any other website.

    I've tried the Apple Discussion Boards during daytime, night time, and very late hours (I'm somewhat of an insomniac) using my MBP at home and it behaves as slow as ever.
     

Share This Page