Internet went down, and now my mac mini is running slow

Discussion in 'Mac Basics and Help' started by aninsincerelove, May 9, 2011.

  1. aninsincerelove macrumors newbie

    Joined:
    May 9, 2011
    #1
    Our internet went down a few days ago. After being out for a day or two, it finally came back on. All of our PCs/xbox's/etc. connect fine, and are running the internet as they had before. My mini, however, is not. Once I get into safari, it has trouble loading pages. Images, videos, everything lags. Heaven forbid I want to load multiple pages at the same time.

    I thought it might by an issue with my mini, so I've been checking around, following what others have been saying but it's never quite tailored to my own problem; and all the fixes just aren't working. We have Qwest, along with the PK5000 as our modem. I've seen issues with this modem, but most have issues connecting with it to begin with; my mac was connected with it fine before the internet went down. My mini's usually connected through airport.

    But now, I'm thinking the outage messed up our modem. While using my iPhone for the past few days, every now and again it will tell me I'm not connected to the internet. I use our PK5000 to connect to the internet while I'm home so I don't waste my data plan, and the last few days I've had to go through and reconnect to our network; sometimes it can't even find the network on the first try.

    I'm not sure what the issue is anymore. If the other PCs and devices are having no issues, why are only my apply devices having problems?
     
  2. rdowns macrumors Penryn

    rdowns

    Joined:
    Jul 11, 2003
    #2
    Reboot modem, router and devices. Always the first step with problems like these.
     

Share This Page