interpret my iRecovery message

Discussion in 'iPhone Tips, Help and Troubleshooting' started by rubirock, Mar 29, 2010.

  1. rubirock macrumors regular

    Joined:
    Aug 12, 2009
    Location:
    Little Beirut
    #1
    short version: 3g, 3.1.2, 5.11.07 stuck in recovery loop. when i attempt to restore, i get stalled at the apple logo w/progress bar, then phone reboots back to "connect to itunes" and itunes gives me "unable to restore. unknown error 28". slightly longer version here

    here is what i get when i run iRecovery

    i cant get iRecovery to do much else (printenv,set auto-boot true, saveenv commands just return to the next line) except "reboot".

    any ideas?
     
  2. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
  3. rubirock thread starter macrumors regular

    Joined:
    Aug 12, 2009
    Location:
    Little Beirut
    #3
    thanks, aggie
    i am pm'ing jav6454 to see if he can shed some light on what exactly can be done to fix the phone, as i am out of applecare.
     
  4. rubirock thread starter macrumors regular

    Joined:
    Aug 12, 2009
    Location:
    Little Beirut
    #4
    well, i went to my genius appt today, but no luck. the genius said that all they would have done would be to try a restore in DFU, but since i'd already tried it, we didnt even bother. i'm 3 months past apple care so they offered to replace it for the standard $199, but there's no guarantee that it would have 3.1.2 fw so i could use it w/Tmobile.

    overall i'm happy with the apple service and will probably buy more applecare for my mbp as a result. plus they were cool about jb/ul and said they would have replaced it if it was still under a/c.

    anyways, so i guess i'm SOL :(
     
  5. spader macrumors newbie

    Joined:
    Jul 30, 2007
    #5
    Acquired used. Do not know what firmware it is. Used different ispw's ranging from 2.2 - 3.1.2 Getting various errors 9, 23, 28, 1604, 2001.

    Should I count my losses?

    Here's my printenv report from iRecovery

    [FTL:MSG] Apple NAND Driver (AND) RO
    [NAND] No supported NAND found
    NAND failed initialisation
    Boot Failure Count: 0 Panic Fail Count: 0
    Entering recovery mode, starting command rompt
    ] printenv
    config_board = 'n82ap'
    loadaddr = '0x9000000'
    boot-command = 'fsboot'
    idle-off = 'true'
    boot-device = 'nand0'
    boot-partition = '0'
    boot-path = '/System/Library/Caches/com.apple.kernelcaches/kernelcache.s5l8900x'
    display-color-space = 'RGB888'
    display-timing = 'optC'
    P bootdelay = '0'
    P backlight-level = '34'
    P platform-uuid = <DATA>
    P a = 'bbbbbbbbb1bbbbbbbbb2bbbbbbbbb3bbbbbbbbb4bbbbbbbbb5bbbbbbbbb6bbbbbbbbb7bbbbbbbbb8bbbbbbbbb9bbbbbbbbbAbbbbbbbbbBbbbbbbbbbCbbbbbbbbDbbbbbbbbbEbbbbbbbbbbbbtbbbbbbbbbubbbbbbbbbvbbbbbbbbbwbbbbbbbbbxbbbbbbbbbybbbbbbbbbzbbbbbbbbbHbbbbbbbbbIbbbbbbbbbJbbbbgeohotbb'
    P restored-exit-status = '0x100'
    P boot-args = 'rd=md0 nand-enable-reformat=1 -progress'
    P auto-boot = 'false'
    image-version = '0x3'
    framebuffer = '0xfd00000'
    secure-boot = '0x1'


    I realize the "Nand Failed Initilization" is the limiting reagent.

    Help please.
     

Share This Page