Invalid allocation units in SSD

Discussion in 'MacBook Pro' started by jimray, May 6, 2012.

  1. jimray macrumors member

    Joined:
    Apr 24, 2012
    #1
    About ten days ago I bought a crucial 256, I was very worried about reliability. Used it and was loving it. Been downloading for about 36 hours straight went one of the hd movies I got wouldn't copy off the drive, gave error. I ran disk utility, said restart to repair/reinstall screen, choose disk utility. Did that, said invalid allocation units, could not be repaired, only re-format. Tried to re-start MBP, and it shut down on white screen.

    Is this common with SSD? Maybe because I was downloading and moving so many large files?

    I can't deal with this type of problem all the time, I'm obviously returning the drive tomorrow, dunno if I should give up on SSD or try again. Any thoughts?

    -irritated
     
  2. Ccrew macrumors 68020

    Joined:
    Feb 28, 2011
    #2
    Maybe it's karma for pirating?
     
  3. jimray thread starter macrumors member

    Joined:
    Apr 24, 2012
    #3
    Sorry, wasn't pirating, was downloading from my own online storage. Rather than storing everything on two external drives, I prefer to put everything online.

    Anyone have any real ideas about what may have caused this error after working for ten days no problem.
     
  4. jdwagner888 macrumors regular

    Joined:
    Feb 4, 2011
    #4

    How can you possibly make that assumption with all of the possible legit ways to download movies/music/ect now-a-days?

    Not everyone is pirating out there.


    Edit: sorry op, I really do not have any answers for you other than maybe a faulty drive.
     
  5. Ccrew macrumors 68020

    Joined:
    Feb 28, 2011
    #5
    Hence "maybe" :) Serious lack of humor around here. But actually, when's the last time it took 36 hours for you to download music?

    Sounds like possibly a bad NAND unit in the SSD, but I'd start by running a permissions check/rebuild on the drive which you did, but from there sounds like it couldn't reallocate the data. Possibly data corrupt, could try deleting what you downloaded (I know, sucks, but could also copy to external) and running through all you've run through again.

    Thought here being on a long download it's possible there was a blip and some data corruption that Disk Utility can't handle.
     

Share This Page