Invalid b-tree node size

Discussion in 'iMac' started by stark93, Dec 12, 2013.

  1. stark93, Dec 12, 2013
    Last edited: Dec 16, 2013

    stark93 macrumors member

    stark93

    Joined:
    Sep 18, 2012
    #1
    Hello everyone,

    I have a 2013 27" iMac with a 1TB Fusion drive in it. Yesterday I was just browsing the internet on Safari when all of a sudden my computer just froze up. I thought it was just Safari and all it's snippyness :p but I couldn't even force quit it. So I just held down the power button till it shut off. When I turned the computer back on, it just displayed a flashing folder with the question mark on it. I though ok? No big deal, I have my time machine backups. So I booted into the recovery mode and went into disk utility and erased the Mac OS X partition. After that I then attempted to restore my system from the latest time machine backup. It said it could not do that and to restart my computer and try again. I got the same results. So I then tried to install a clean copy of 10.9 and got the same message. THEN tried internet recovery with the SAME message...

    I booted back up into recovery mode (all this time running off my time machine backups) and do into disk utility again. I clicked on verify to verify the Macintosh HD Not the Mac OS X partition. I came up with the error message "invalid b-tree node size. This disk needs to be repaired." So I click repair and it just says the same thing. Disk utility can not repair the disk.

    So I don't know what is going on? I guess my hard drive it just completely shot?

    Basically my question is this... I do have access to the terminal. Is there anyway I can completely reformat the Macintosh HD? I do mean the Macintosh HD. Not erase the Mac OS X partition even at the most secure leave because that does not work.

    Either way I have a Genius Bar app. Friday, but any help is very much appreciated! :)

    Thank you for your time!


    After talking to someone at the Genius Bar, all they did was dump the image for Mavericks on my HD. Then did NOT solve my issue. My disk needed to be repaired.
     
  2. Bear macrumors G3

    Joined:
    Jul 23, 2002
    Location:
    Sol III - Terra
    #2
    If you've booted into recovery and tried to erase the OS X partition and that didn't work then your disk is toast.

    Do you remember what brand the hard drive was?
     
  3. stark93 thread starter macrumors member

    stark93

    Joined:
    Sep 18, 2012
    #3
    I don't know? My guess would be Seagate. But it's just whatever the stock Fushion drive is that came with the iMac when I bought it.
     
  4. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #4
    DiskWarrior may be able to repair that error. Do a little research before purchasing it, though.
     
  5. stark93, Dec 14, 2013
    Last edited: Dec 16, 2013

    stark93 thread starter macrumors member

    stark93

    Joined:
    Sep 18, 2012
    #5
    Success - Disk Repaired

    I did look into disk warrior, but that was no help. I was unable to boot into it.


    I know it is a problem that happens every once in a while so I'd like to let everyone know how I solved the issue.

    As stated before, my main problem was when I verified my disk I had the error:
    Invalid b-tree node size
    The volume could not be verified completely.

    Disk utility could not repair the disk.

    Here is how I solved the issue and repaired the disks:

    1. If you haven't already, go ahead and back up your Mac with Time Machine.
    2. Create a Windows 7 or 8 bootable USB using Bootcamp Assistant.
    3. Boot into Windows 7 or 8 on your Mac.
    4. Follow the setup until you have the option to choose what drive you can install Windows on.
    5. Delete every drive/partition EXCEPT for the Windows 7 or 8 USB you created.
    6. After the drives have been completely erased, click exit and shut down your system.
    7. Clear your Mac's PRAM by holding down command+option+P+R until your Mac starts up a second time. Generally between 15-30 seconds.
    8. Restart your Mac once more while holding the option key down, boot into your Time Machine Backups disk, and then restore from your latest back up.

    I looked non-stop for 4 days to find a fix, there is nothing out there. A lot of people suggest using Disk Warrior, but I did not have success with that plus it's $100.00. If your having this problem with your internal drive, give this a shot. Leave your results.
     
  6. SaSaSushi macrumors 68040

    SaSaSushi

    Joined:
    Aug 8, 2007
    Location:
    Takamatsu, Japan
    #6
    First of all, glad to hear you solved your problem.

    Repartitioning/reformatting, when possible, will always fix B-tree node size errors.

    The problem is that sometimes machines with such errors have file system damage to the point of being unbootable. This is where a utility like DiskWarrior can save the day, by repairing with the data intact. This is why it is called data recovery software and why it's not cheap.

    You were fortunate to have been able to backup, reformat and reinstall. Others with such problems may not be so fortunate.

    Of course, the moral of the story is always to backup, backup, backup. I use Time Machine, a local clone of my Macintosh HD done daily to an external HD and a full system backup in the cloud to Crashplan.
     
  7. stark93 thread starter macrumors member

    stark93

    Joined:
    Sep 18, 2012
    #7
    True! I did try DiskWarrior 4.4, the latest version, but I was unable to boot from it. I had the option to boot into it but when I did choose Disk Warrior instead of Mac OS X it would begin to boot into it then freez up and the message saying something went wrong and to please restart my computer with the power button in th back ground would be displayed.
     
  8. ccmail111 macrumors newbie

    Joined:
    Nov 11, 2014
    #8
    how was the issue resolved ?

    re:
    when I verified my disk I had the error:
    Invalid b-tree node size
    The volume could not be verified completely.

    Disk utility could not repair the disk.

    As mentioned, SaSaSushi, I agree and currently I am in that situation where the Mac does not boot up at all.
    On other hand I read stark93: Disk Warrior did not work.

    How was this resolved finally if Mac does not boot up ?
    The fsck seems ok (in single user mode) and thus does not seem as hardware issue.
    I cannot format drive since I have not backed up data.
    Has anyone faced this issue ? Any pointers ?

    Thanks !
     

Share This Page