Invalid IP provided to some devices by Time Capsule

Discussion in 'Mac OS X Server, Xserve, and Networking' started by igal27, Apr 12, 2011.

  1. igal27 macrumors newbie

    Jun 20, 2010
    I posted a question here earlier but didn't get any feedback; now I have a little more info to add which might help.

    I connect with a MacBook Pro to a home wireless network created by a Time Capsule (1 TB). The Time Capsule is connected via a cable modem. When connecting with my MacBook, I get a valid IP address and have internet access. 2 visitors with iPhones have also managed to successfully connect (and get valid IPs and internet connection), as has another MacBook Pro. Conversely, 2 iPods and another MacBook Pro have NOT managed to get a valid IP and internet connection. To be precise, they manage to connect to the wireless network (WPA2 security), but the router doesn't give them a valid IP address (they get a address). It doesn't matter if I reset everything and try to connect with these devices first (such that they are the first ones to connect to the wireless network), including after resetting the Network Settings on the iPods -- they always get the 169.x IP address.

    I compared all the settings on my MacBook (the one that gets a valid IP) and the MacBook that got the 169.x IP address, and found no differences -- all settings were identical.

    I do NOT have Mac address blocking on in the Time Capsule.

    When I connected the MacBook (that didn't get a valid IP from the Time Capsule) directly to the ethernet cable from the cable modem, it DID get a valid IP.

    The problem therefore seems to be with the Time Capsule. Question is -- what can I do to fix it?

    Help!!! Thanks :)
  2. velocityg4 macrumors 601


    Dec 19, 2004
    Try disabling all network encryption and connecting everything. Then you can try enabling the network encryption again.
  3. igal27 thread starter macrumors newbie

    Jun 20, 2010
    Thanks, I'll try that next chance I get (when someone with another device comes by to visit...)
  4. Sonicjay macrumors 6502a


    Jan 1, 2008
    Just an fyi, IP addresses in the 169.x.x.x space are referred to as APIPA addresses (automatic private IP addressing), and are addresses that devices assign to themselves when they don't receive a DHCP address. Your Time Capsule is not handing out bad addreses to the devices that don't connect, they simply aren't getting one, so they give up and self-assign an APIPA address. This can happen if the WPA passcode is entered wrong, as well as a lot of other reasons depending on how complex the network is, but more often than not, if other devices can authenticate to the wireless SSID and get an address, it's a typo on the passcode, or possibly devices that don't support wpa2, etc.
  5. igal27 thread starter macrumors newbie

    Jun 20, 2010
    Okay, I ended up figuring out and solving the problem. This will probably be obvious to some, but others may benefit from the solution if they're experiencing the same problem, so I'll post it here.

    I started by changing WPA2 security to WPA/WPA2 (in case it was an authentication problem via WPA2), but that didn't help. I then removed security altogether (temporarily, of course), and was surprised to find that that didn't help either... I then realized the problem was that I wasn't receiving an IP from my Internet Service Provider (ISP) for more than 2 devices (actually 3: my router was getting one, and two other devices that I connected to the wireless network). As my ISP was not willing to provide support for my router (as it was purchased privately, not through them -- very annoying...), I started trying to understand and playing with the various configuration options on my own.

    It turns out the problem was with the "Connection Sharing" option (in Airport Utility, under the Internet menu, under the Internet Connection tab). Mine was set to "Off (Bridge Mode)" -- which I now understand means that every device that connects to the wireless network attempts to obtain an IP address from the ISP via DHCP. The problem is, my ISP apparently is only willing to provide 3 such distinct IPs for my account (they didn't say anything about this, but that's what I saw in practice...), so once 3 devices (including my router -- the Time Capsule) had been connected, it would not give out any more IPs, and the device would consequently self-assign one (169.x.x.x), leading to the problem I described.

    So, I tried the other Connection Sharing options (not really understanding at first what I was doing...). I started with the wrong choice, "Distribute a range of IP addresses" -- I guess only the ISP can do this (i.e. distribute fixed "real" IP addresses within a given range that belong to the ISP). I then tried what turned out to be the correct choice: "Share a public IP address". This took the single unique IP that the router got from the ISP via DHCP, and shared it among whatever devices connected to the home wireless network, distributing IPs in the range -> 200 (so I guess in principle, I can connect 199 devices...). At first it didn't work -- i.e. I managed to connect with all devices and get an IP (10.0.1.x), but I couldn't connect to any website from Safari, or use the AppStore, or Mail, or any other application that needed an internet connection. I then realized there was one more piece of information I still needed to enter: DNS servers. This is entered in Airport Utility under the Internet menu, under the TCP/IP tab, in the DNS Server(s) field. There are two fields here, I guess most ISPs have 2 DNS servers (mine did). I obtained the numbers from what appeared automatically when my computer previously got an IP directly from the ISP by DHCP when I had the Time Capsule set to Bridge Mode, which I found in the Network Preference Pane (by clicking "Advanced...", and then selecting the DNS tab) -- but I guess you can also just call your ISP and ask them for the address(es) of their DNS server(s).

    In any case, once I did all that, any device I connected to the network got an IP starting at (next one gets, etc.), and they all point to for DNS (which then gets the actual DNS numbers from what I entered previously in the Airport Utility). This setup works and allows multiple devices to use the internet connection simultaneously (I've tried it with 4 devices connected simultaneously -- works like a charm...).

    Like I said at the beginning, I'm sure much (if not all) of this will be obvious to many, but for people like me (who manage quite well with computers, but just don't know much about wireless networking), I hope it may be of help.

Share This Page