Invalid node structure after latest security update

Discussion in 'Mac OS X Lion (10.7)' started by vicviper789, Jun 5, 2013.

  1. vicviper789 macrumors newbie

    Joined:
    Jun 5, 2013
    #1
    Welp, I am getting an Invalid Node Structure notice after trying to update to the latest security patch through software update. Tried fsck'ing, tried Disc Utility, tried single user mode all with no luck. On start up, it goes to the apple logo with the gray clock wheel and a progress bar then shuts off. Looks like I will have to back up my HDD then restore it to another drive and do a clean installation or something. I haven't tried to pull out the HDD yet, but it would be nice if there was an "undo last update" terminal command.


    When macs break, they break:rolleyes:
     
  2. benwiggy macrumors 68020

    Joined:
    Jun 15, 2012
    #2
    There is. It's called "a backup".
    However, your problem is a corrupt disk file structure. It has nothing to do with the security update, except that it possibly exposed the problem by writing to the corrupted area.

    When hard drives go bad, they go bad, and you should be ready for this with a backup.

    Erase the disk and restore from your last backup.
     
  3. vicviper789 thread starter macrumors newbie

    Joined:
    Jun 5, 2013
    #3


    Oh you :p Typical mac guy.


    Anywho, I made a back up and re-installed the OS. All's well now. I still say it was apples update that caused the problem. ;)
     
  4. Bear macrumors G3

    Joined:
    Jul 23, 2002
    Location:
    Sol III - Terra
    #4
    I highly doubt it was the update and agree with benwiggy that you exposed an existing condition.

    Do verify your file system every couple of weeks for a while. What happened could be a one time incident or it could be indicating that your disk is starting to go bad.
     
  5. benwiggy macrumors 68020

    Joined:
    Jun 15, 2012
    #5
    As a typical Mac guy, I've seen well over 40 point updates to OS X since 10.2, and about the same again in security and "other" updates. Every one of them has produced posts saying "OMG, Apple's update broke my computer". And there's probably been about 2 where that was actually the case.

    Unless a large section of Mac users with similar hardware experience a similar fault: it isn't the update.
     

Share This Page