Invalid Node Structure and Not Starting Up

Discussion in 'MacBook' started by brokenshoes, Jun 1, 2009.

  1. brokenshoes macrumors newbie

    Joined:
    Feb 25, 2009
    #1
    Last night I was using my MacBook (OS X 10.4.11 (I think it's 11, I can't remember for sure, the latest one)) when all the programs that were running froze. I shut down the computer and went to reboot however when it rebooted all the got was the chime and not apple or pinwheel. In the end, I ran the Hardware Test and it came back clean so I went into Disk Utility and checked that, it came back with "Invalid Node Structure" etc so I tried to repair it and that failed.

    Now I read this thread and understood most of it except for how actually do a repartition.

    I don't have Disk Warrior so that's out, but I don't care about losing files or data or anything, I have an external hard-drive and luckily I actually copied everything that was important onto it a couple hours before this happened while I was cleaning the MacBook out.

    So basically my question(s) is/are; how do I do a repartition, why did this happen and is there anything I can do to stop it from happening again?

    Thanks.
     
  2. andalusia macrumors 68030

    andalusia

    Joined:
    Apr 10, 2009
    Location:
    Manchester, UK
    #2
    I'm afraid I cannot say why this has happened, or how to prevent it.

    However I think you can partition your hard drive using Disk Utility, if you can access that then you should be able to do it. Click on the hard drive in the left sidebar (The drive itself, eg 111.8GB FUJITSU MHZ2.. etc etc rather than, for example, Macintosh HD). You should be able to do it under the partition tab after that.
     
  3. brokenshoes thread starter macrumors newbie

    Joined:
    Feb 25, 2009
    #3
    I tried that and now I'm getting this:

    "This drive has reported a fatal hardware error to Disk Utility. If the drive has not failed completely, back up as much data as you can and then replace it with a working drive."

    I re-ran the Hardware Test and it's still coming back with no problems. I'm at a lose as to what to do, should I reformat or something?
     

Share This Page