Invalid response when backing up 6S

Discussion in 'iPhone' started by PSteen, Mar 22, 2017.

  1. PSteen macrumors newbie

    PSteen

    Joined:
    Mar 22, 2017
    #1
    When trying to backup my S6 to the laptop I get the following message " I Tunes could not connect to I phone PSteen because an invalid response was received from the device". Please give advise how to rectify too be able to backup.
     
  2. Shirasaki macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #2
    Here are a few tricks I use during backup.

    Keep your phone on home screen at all times. This could sometimes be the best way to ensure a successful iTunes backup.

    Unplug and plug your devices. Some "invalid responses" are from loosen connections.

    Restart or hard reset your device once or twice. This could also help.

    Change another cable or another USB port, or both.
     
  3. Newtons Apple Suspended

    Newtons Apple

    Joined:
    Mar 12, 2014
    Location:
    Jacksonville, Florida
    #3
    Make sure you are using the latest version of iTunes.
     
  4. bufffilm Suspended

    bufffilm

    Joined:
    May 3, 2011
    #4
    There should be no reason to update iTunes just to backup the device if iTunes is already installed.

    I always keep a back up copy of the iTunes that was installed in case a reinstall is needed.

    But putting a later version of iTunes on top of an older version (esp. if the Windows version has changed) can bring it own share of headaches.

    Happened to my sister...I had to fix (and it involved a little work).
     

Share This Page