Invalid Sibling Even After Formatting

Discussion in 'Mac Basics and Help' started by bigglefuzz, Feb 13, 2010.

  1. bigglefuzz macrumors newbie

    Joined:
    Feb 13, 2010
    #1
    My Intel iMac (2.4) has invalid sibling links even after completely formatting. I have managed to get Leopard installed, but it is constantly beech balling and generally acting unstable.

    It started off with refusing to boot and under the 'alt' boot menu it showed the Mac partition as 'EFI Boot'. I tryed to repair this using fsck and disk utility but to no avail.

    I formatted the system and tried to install Snow Leopard, but the installation failed several times, each time at different points.

    I managed to get Leopard (10.5) installed. HOWEVER, if I run disk utility, I still get invalid sibling links and as I said earlier, it keeps beach-balling and probably won't continue working.

    I have run some memory tests and it passed all of the tests with flying colours. I'm just left wondering what else could be causing these problems. Thank you.

    Edit: I also have a 25gb Boot Camp partition at the end of the disk which is working 100% fine.
     
  2. velocityg4 macrumors 68040

    velocityg4

    Joined:
    Dec 19, 2004
    Location:
    Georgia
    #2
    Could be a faulty hard drive or motherboard. Is the install DVD scratched or have any other damage?

    If your iMac is no longer covered by Applecare you could get Techtool Pro to run hardware diagnostics. You may have to set the tests on multiple loops (50 or more) to reveal the problem if not immediately detected. I would run disk and other tests separately to keep the motherboard components under load.

    Alternatively if you have a spare hard drive you could swap that with your internal and try installing OS X on to that. I would also try running the install with only one RAM stick installed at a time, not knowing what RAM tests you performed nor their duration. This would allow you to tick off possible parts causing the problem. If none of these changes clears the problem then the motherboard would be the most likely culprit.

    For all of these tests you should have all peripherals removed besides the keyboard and mouse.

    If you still have Applecare then let Apple deal with it.
     
  3. bigglefuzz thread starter macrumors newbie

    Joined:
    Feb 13, 2010
    #3
    I've been wrestling with this for a couple more days now, and a few things I have done.

    The RAM tests were done with TechTool Pro and I am running another as I type. These showed no kind of problems, and I have repeated them several times, including once after some intensive HD video viewing, and even the hour long test. None of them showed any problems.

    The Disk test in TechTool Pro showed no problems either for the first 80%. Then it crashed and I was unable to finish the test. It could be errors nearer the end of the hard-drive, but I will have to leave the tests on again overnight to verify.

    The fact that none of these problems show on the windows partition I have though, makes me more confused. Even after an intensive gaming session of Bioshock 2, absolutely nothing went wrong and not a single hang up or crash (except when I tryed to alt-tab and cheat :p). It could be the HDD is physically damaged in a certain place which exists outside the windows partition.

    I am no longer under Applecare so going to the Apple store is not only costly but also a bit out of the way. Plus they take 3 weeks to do repairs of this kind from what I hear. I could probabaly manage to replace a HDD myself though, but from the videos I've seen it looks to be quite tricky on the iMac and involves suction cups, specialist voodoo and bodypainting during a lunar eclipse.

    I did managed to get 10.5 installed though after about 3 tries. I really have no idea what could be causing this besides a hard drive error that fails to show up on the SMART and isn't just corruption of the file-system. The DVD definitely isn't scratched, and that wouldn't explain the constant 'Invalid Sibling Links' that I keep getting. The OS X installation that I managed to get working is constantly crashing and beach balling when even just browsing the internet or just opening new tabs.
     
  4. chrismacguy macrumors 68000

    Joined:
    Feb 13, 2009
    Location:
    United Kingdom
    #4
    Sounds like you could need a new HD - Luckily for you theyre user-replaceable and not exactly expensive - just get a new 500GB or 1TB drive and try installing Leopard onto that - hopefully thatll be much more stable ;)
     
  5. bigglefuzz thread starter macrumors newbie

    Joined:
    Feb 13, 2010
    #5
    iMac O.O

    Nah, I found an external HDD that I'm installing OS X on. If that work's well I'll go out and buy a 1TB HDD. I'm sure I'll use the space. :)
     
  6. chrismacguy macrumors 68000

    Joined:
    Feb 13, 2009
    Location:
    United Kingdom
    #6
    The HD is easy-ish to replace on every model except the Mac Mini and I know it was definitely supported on the 2006-2008 iMacs because I supported them in a lab config and had to replace drives in them occasionally. (AFAIK it is only the Mac Mini that Apple doesnt accept that the HD and RAM are user-replaceable).
     
  7. bigglefuzz thread starter macrumors newbie

    Joined:
    Feb 13, 2010
    #7
    It's good to know that it isn't as hard as I think then.

    I found this article at http://www.amfiteatar.org/content/view/155/78/lang,en/ which shows how to pull it off, both literally and metaphorically.

    Main points for future googlers.

    Suction cups to remove the glass screen, TORX screwdrivers to remove the LCD. Careful with ribbon cables and should be good as roses.

    BTW. I am 100% sure it is the HDD, or possibly the HDD controller (rare but still possible). I am running now off a USB HDD and trying to copy a file off the internal HDD and it isn't having it. Yet the external USB HDD is running as smooth as a whistle. I'm gonna see if I can get a 1.0 or 1.5 TB HDD tomorrow, I'll let you know how it goes. :D
     

Share This Page