Invalid Sibling Link + Target Disk mode fail-can't back up!! ????

Discussion in 'Mac Basics and Help' started by siblinglink, May 25, 2008.

  1. siblinglink macrumors newbie

    Joined:
    May 23, 2008
    #1
    Hi everybody.. I have a problem! My girlfriend's MacBook Pro w/ OSX 10.4 and I think a 2gig processor with 1.5gig memory stopped fully booting up because of an invalid sibling link (says diskutil) and her computer shuts off while backing up her data to an external HD in Target Disk mode (connected to my MBP).

    It hangs at the grey apple and spinning disk, and then after a couple minutes, it gives the 'no symbol'. I inserted the appropriate Mac OS X Install 1 CD to do archive and install and held C-- same thing happens. Tried the same with TechTools deluxe CD. Tried to boot in Safe mode and single-user, same thing. Resetted PRAM, and NVRAM... Option lets me click the Macintosh HD but it still hangs at grey apple and spinning disk.

    Target disk mode works though, so I try running Disk Utility on her volume-- it gives me the following:

    Checking HFS Plus volume.
    Checking Extents Overflow file.
    Checking Catalog file.
    Invalid sibling link
    Volume check failed.

    Error: The underlying task reported failure on exit

    1 HFS volume checked
    1 volume could not be repaired because of an error


    So I tried all of the above AGAIN. To no avail. SO, I decided to just go ahead and back up her drive-- I connected her MBP to my MBP in Target Disk mode and tried to transfer her files to the external HD I had hooked up as well-- after maybe two hours, her MBP had just shut off. It was connected to it's power cord..

    What should I do? I need to back up her data but I can't in TDM because it shuts off. It's 90 gigs worth of data. I could also Archive/Install from my MBP with hers in TDM but obviously it would shut off.

    How should I back up her data?

    I also need to figure out if she should drop $100 on DiskWarrior and pray, or go ahead and get a new hard drive.


    :(
     
  2. merl1n macrumors 65816

    merl1n

    Joined:
    Mar 30, 2008
    Location:
    New Jersey, USA
    #2
    Since you reset the PRAM, I would also do an SMC reset on it. Then try to boot in Single User mode. If you can, run this command:

    /sbin/fsck -fy (hit a return key)

    If it comes up with errors, run it again. Keep running it until you get a clean pass.

    Then type:
    reboot

    If you can't boot Single user mode, try target mode using your other mac. Once the volume is mounted, use the Terminal app and become the root user:

    sudo -s

    Then type the following command:

    diskutil list

    This will list out all of your disks and the bad mounted volume. Example from mine:

    What you want to identify is the disk slice of the bad volume. Example:

    Suppose I had the same problem with my volume Inferno. If you look at the above listing you will see that it is "disk0s4"

    Now that you have identified the disk slice you can run an fsck on it in Terminal (I'll use mine as an example):

    fsck -fy /dev/disk0s4

    Again, run it (up to 5 -6 times) until you get a clean pass. If it is still having errors, your disk may be totally hosed.

    To exit out of the root user in Terminal, type

    exit

    Also I do recommend getting Disk Warrior as it is a great utility and can fix multiple problems that even Disk Utility can't.
     
  3. siblinglink thread starter macrumors newbie

    Joined:
    May 23, 2008
    #3
    Hey merl1n, thanks for the help. SMC reset didn't help anything, and I can't get to single-user.. I tried running fsck -fy on the bad disk in target disk from my MBP and got the following:

    Same thing every run (6 runs)... I guess her HD is screwed? Is there still a chance DiskWarrior could fix it or should she just get a new HD?

    Also, any idea about her MBP dying while in target disk mode and how I can back up her data in this situation? (Other than doing small chunks at a time which would take an immense amount of time)

    Thanks again for your help :)
     
  4. merl1n macrumors 65816

    merl1n

    Joined:
    Mar 30, 2008
    Location:
    New Jersey, USA
    #4
    In this case, I don't think that even Disk Warrior can help. On a file system/disk the Superblock contains all of the inodes (pointers) to where files and their fragments are located. In essence the entire directory structure. When a new file system is made, a Superblock is created and multiple copies of this Superblock are written to various sectors on the drive. This is an insurance policy, so if the main Superblock can't be read, an alternate can be used since it contains the same data.

    In you case, it can't read any of them. Your disk is hosed and failing (hardware wise).

    It sounds like your disk is going offline at random times while the OS is trying to update (read from memory/write to disk) the disk and this will cause serious data corruption. This may also explain why your Mac is shutting off randomly although if it were just the disk, I think you would see a kernel panic instead.

    Now, this could be a problem with the System board itself causing the drive failures and not the drive itself.

    What you should do first is this:

    1. Insert the original OS DVD in the MBP while it is on.
    2. Power off the MBP
    3. Power on the MBP and immediately hold down the option key until you see the boot loader screen (blue screen showing bootable volumes).
    4. Select the Apple Hardware test
    5. Run the quick test first. If you see any error, write it all down exactly as it appears. If no errors, go to the next step.
    6. Run the extended test and do the same for any error message.

    If you see an error, call Applecare and open a case.
     
  5. siblinglink thread starter macrumors newbie

    Joined:
    May 23, 2008
    #5
    Thanks again merl1n! I found that I'm able to boot off the install CD if I use option during start-up and then boot off the CD-- that just brought me to installer... so once I get her data backed up I can try an erase/install.

    but anyway, to get to the hardware test I held D on startup...

    I got this error from the hardware test (same for basic and extended):

    4MOT/1/40000002:Left_Middle-Front

    A google search suggests that it's a common fan problem.

    There's no warranty left on it.. if I call AppleCare, won't they just tell me to deal with it?


    I guess I'll just transfer small chunks of personal data to backup.
     
  6. merl1n macrumors 65816

    merl1n

    Joined:
    Mar 30, 2008
    Location:
    New Jersey, USA
    #6
    Sorry that it is not under warranty or Applecare extended coverage.

    Yes it could be just a fan problem or it could be a logic board problem not seeing the fan.

    Your best bet is to find a 3rd party outfit and get it fixed. There are many online.
     

Share This Page