Invalid sim!!! No sim inserted!!!

Discussion in 'iPhone' started by salacious, Jan 7, 2012.

  1. salacious macrumors 6502a

    Joined:
    May 15, 2011
    #1
    what the hell my iphone all of a sudden today has been saying no sim inserted or invalid sim, i fixed it earlier by doing a hard reset (power and home button) but now when i try it, it doesnt work?

    iv had a month after release date, in the uk, from apple so its unlocked im using giffgaff simcard, but my gf has one too and its not happening to her??

    any ideas? i know there was something before about invalid sims, but i thought apple fixed this?
     
  2. apollo1444 macrumors 65816

    Joined:
    Jul 22, 2011
    Location:
    mexico
    #2
    have u tried updating to 5.0.1 the latest build? 5.0.1 (9A406) it fixes the invalid sim errors
     
  3. salacious thread starter macrumors 6502a

    Joined:
    May 15, 2011
    #3
    its already on 5.0.1?
     
  4. verwon macrumors 68030

    verwon

    Joined:
    Jul 26, 2011
    Location:
    Seattle
    #4
    Reread, it's a new build of 5.0.1 that was supposed to fix that error.
     
  5. salacious thread starter macrumors 6502a

    Joined:
    May 15, 2011
    #5
    oh ok seen it restoring now, hopefully it works...
     
  6. apollo1444 macrumors 65816

    Joined:
    Jul 22, 2011
    Location:
    mexico
    #6
    there are two versions of 5.0.1? :rolleyes: check the build number willya?
     
  7. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
  8. salacious thread starter macrumors 6502a

    Joined:
    May 15, 2011
    #8
    i updated and i now no longer have problems, thanks for the info how do i close this thread?
     

Share This Page