Invisible Download Files

Discussion in 'MacBook Pro' started by Snob, Jun 21, 2011.

  1. Snob, Jun 21, 2011
    Last edited: Jun 21, 2011

    Snob macrumors newbie

    Joined:
    Jun 21, 2011
    #1
    Not really sure where this thread belongs, so if this is the wrong section, move it as you please.

    Anyway, my problem has occurred in the past month, and it's rather annoying. I'll be downloading a file, be it from Safari or uTorrent, and the file will be displayed in my Downloads folder while it's being downloaded. Once the file has fully downloaded, the file(s) is nowhere to be found. My Downloads folder will be empty. However, if I do a search for the file I just downloaded, I'll find it, no problem. When I open the file's enclosing folder, I find the file located in the Downloads folder. If I then proceed to manually open the Downloads folder, the file still remains invisible.

    I have no idea what has triggered this strange phenomenon, as I have not done anything unusual or out of the ordinary in the past month. Any suggestions or solutions would be greatly appreciated.

    Forgot to mention; I have an early 2011 MBP.
     
  2. ormie macrumors regular

    ormie

    Joined:
    Feb 25, 2009
    #2
    Check in Safari's settings in Preferences and see where downloads are set to go. You can chose to have them saved to the download folder. Also, have a look in Finder, and see where the download folder is, if the downloads are there you can drag that folder to the tool bar and a copy of the filer will stay there. The other way is to make your own folder to save to and direct the downloads to it and again, have a alias folder in the tool bar. Just be careful what settings you have for downloads: make sure you have it set NOT to open safe files when downloaded or you'll end up with something you do not want.
     
  3. Snob thread starter macrumors newbie

    Joined:
    Jun 21, 2011
    #3
    Well, I already have my Downloads folder on my toolbar, and in the past all downloads were automatically placed in there (from all sources: e.g Safari, uTorrent). Now while a download is in progress, the file appears in the Downloads folder, but once the download completes, the file is completely invisible; I open the Downloads folder and there's nothing there. No trace of anything. If I do a search in Finder for the file, I find it, and the enclosing folder is still the "Downloads" folder. But opening the Downloads folder itself, I see no trace of any downloaded files...

    I know it probably sounds a bit confusing. I already have both Safari and uTorrent store my recent downloads in the "Downloads" folder, and they do... except the files turn invisible until I manually search for them through finder. Just by opening the Downloads folder I find nothing.
     
  4. Dark Void macrumors 68030

    Dark Void

    Joined:
    Jun 1, 2011
    Location:
    Cimmerian End
    #4
    it may be too simple of a fix, but try dragging your downloads folder off of your dock. download something and find the enclosing folder (located in downloads as you say), and drag that to your dock. download something else and see if that helps.
     
  5. Snob thread starter macrumors newbie

    Joined:
    Jun 21, 2011
    #5
    Did not work...

    It's so weird. Opening my Downloads folder virtually displays nothing, but typing the file name in the search field does...

    EDIT: Now I just found a file I recently downloaded in the Trash. I haven't done anything besides downloading it, so how it ended up there I do not know. This has happened before, as well. Downloads in progress appearing in Downloads folder, and when it's completed, it's to be found in the trash. Either trash or nowhere...
     
  6. ormie macrumors regular

    ormie

    Joined:
    Feb 25, 2009
    #6
    Hmm, might be an idea to do a back up and then do a clean install of the OS but give repair permissions a try first using both the original install disc and disc utilities. Something had been changed and is causing this to happen, very odd.


    Cheers, Macjim.
     

Share This Page