Invisible text in Pages/iWork '08 on Mountain Lion

Discussion in 'Mac Apps and Mac App Store' started by Highlander-, Jul 30, 2012.

  1. Highlander- macrumors member

    May 15, 2012
    I installed iWork '08 with Pages, Numbers and Keynote on my newest Mac running Mountain Lion. I entered my serial number and the installation completed.

    My problem is none of the applications are working properly: they all load and open but once opened they do not allow any noticeable input...

    In Pages it appears like the text I type is not being inputted in the document at all, but when I highlight the page with the mouse I can see the text revealed. So the text is all white, or rather, invisible. I did not change the text colour or anything - it is set at default black. This problem happens both when creating a new document and also when opening an old one - all the text is invisible/hidden unless highlighted with the mouse. And when I try to change the highlighted text from black to red it still stays white/invisible.

    It all worked fine before upgrading from Lion to Mountain Lion.

    How can I fix this? Anyone else have the same problem?
  2. Alexey2 macrumors newbie

    Sep 9, 2012
    Hey Highlander!

    I experienced this problem too. The same scenario: I installed OS X Mountain Lion and then I installed iWork 08 from its installation media.

    Eventually App Store app downloaded Pages Update 3.0.3 and Keynote Update 4.0.4 and problems with invisible text in Pages disappeared.

    Strangely enough App Store did not give me any Numbers updates, so I went to the download area of the Apple's support site and downloaded and installed Numbers Update 1.0.3 manually. Here it is: This update fixed the Numbers problems.

    So if App Store does not help you to get iWork 08 updates, here they are:
    1. Pages 08 3.0.3:
    2. Numbers 08 1.0.3:
    3. Keynote 08 4.0.4:
  3. kalsta macrumors 68000


    May 17, 2010
    Thanks so much for that answer… I don't know what happened to the OP, but it helped me! Those updates do indeed fix the crazy reversed colours.

    I discovered that you also need to make sure all apps are contained within a folder named "iWork '08". (I had renamed it to just "iWork", and that prevented the updater from finding the apps. All a bit sloppy Apple!

    Anyway, thanks again!
  4. Alexey2 macrumors newbie

    Sep 9, 2012
    I'm glad it helped you!
  5. The Economist Suspended

    The Economist

    Apr 4, 2011
    Thanks for posting the solution, I had the same problem as the OP.
  6. Alexey2 macrumors newbie

    Sep 9, 2012
    Well, I looked into the problem a little bit more and found some rather interesting stuff.

    First off, the Numbers update 1.0.3 was finally added to the Software Update's update list. So Software Update should now show this formerly missing one.

    Speaking of update lists...

    Mountain Lion on my Mac uses this one:
    Seems Leopard uses this one instead:

    Strangely enough some updates for iWork'08 and iLife'08 which are listed in Leopard's update list do not appear in Mountain Lion's one. Maybe they'll be added in future as it happened with Numbers update 1.0.3...

    This is update list comparison:
                              Leopard   Mountain Lion
    iWork '08
        Keynote 4
            Keynote_404       +         +
        Pages 3
            Pages_303         +         +
        Numbers 1
            Numbers_103       +         +
    iLife '08
        iPhoto 7
            iPhoto_710        +         +
            iPhoto_714        +         +
            iPhoto_715        +         +
        iMovie 7
            iMovie_710        +         +
            iMovie_714        +         +
        iDVD 7
            iDVD_704          +         +
            iDVD7.1.2Update   +         +
        GarageBand 4
            GarageBand_411    +         [COLOR="Red"]- (!)[/COLOR]
            GarageBand_412    +         [COLOR="Red"]- (!)[/COLOR]
        iWeb 2
            iWeb_203          +         [COLOR="Red"]- (!)[/COLOR]
            iWeb_204          +         [COLOR="Red"]- (!)[/COLOR]
    And here is the list of all iWork'08 and iLife'08 updates which can be found at Apple Support Downloads page:

  7. MattMusical macrumors newbie

    Feb 5, 2013

    Apologies for resurrecting a dead thread, but I could really use some help.

    I'm having the exact same problem as described above. I've downloaded all three updates from the links provided; however, I can't activate them because, when I click on them, my Macbook claims they're from an unidentified developer (despite the fact that I downloaded them from Apple Support!).

    I tried moving all three into the iWorks '08 folder, as suggested, but the Software Updater still can't seem to locate them.

    Is there anything else I can do to update iWorks? It's really frustrating to have it sat on my computer and not being able to use it!

    Thanks in advance!
  8. JediMeister macrumors 68040

    Oct 9, 2008
    You might be running up against GateKeeper, the security measure in Lion and Mountain Lion. Instead of double-clicking the installer packages, go to the folder where you downloaded the installer packages for each of the iWork applications and right-click and choose open. The OS will still complain about running an installer from an unidentified developer but you can continue with the installation.

    I would not recommend disabling GateKeeper entirely by going into the Security preferences pane and allowing applications from any source to run unless you are already very careful about what you download and run on your Mac.
  9. Griz Bear macrumors newbie

    Dec 14, 2013
    An update to confirm the validity of the information given by Alexey2 ...

    My situation involves replacing a late 2007 17" MBP, running 10.6.8 and iWork 08 with a new late 2013 15" MBP with Retina running 10.9. Of course the new machine gets the brand new Numbers / Pages / Keynote, which, by now, most people know will not open iWork 08 files.

    To make a long story short, on the new MBP, installed the old iWork 08 & ran up against the "invisible" contents. Found this thread, downloaded the updates and now all is good (in iWork 08).

    Now the trick is to find a cheap iWork 09, upgrade all data files to this version, then they will be openable in the new "iWork" apps.
  10. swiftyj macrumors newbie

    Aug 17, 2014
    I have been through a similar process for different reasons. I had a hard drive crash that lost all data. I reloaded IWork from disc and have the same invisible input issue, Pages 3.0.1, Numbers 1.0.1. I attempted the fix you suggested. Opening the packages generates the message,"An eligible Pages application was not found in the location /Applications."

  11. JediMeister macrumors 68040

    Oct 9, 2008
    You did download the Pages 3.0.3, Numbers 1.0.3 updates, not the ones for later/more recent versions, yes? If you are certain you downloaded the correct updates, make sure that there is in fact a iWork '08 folder in /Applications and that it contains the Pages, Keynote, and Numbers applications. If it's not there, you may have chosen to only install for a particular user instead of for all users; it may be in ~/Applications instead. If the applications are not where they are supposed to be, the update packages won't install because they can't find what they are looking for where it expects them to be.

Share This Page