Invoked by apple software

Discussion in 'OS X Mavericks (10.9)' started by luisfelipetrigo, Feb 3, 2014.

  1. luisfelipetrigo macrumors newbie

    Joined:
    Sep 13, 2011
    #1
    I have an iMac, early 2008, with 6 GB RAM.
    Two days ago I upgraded to Mavicks.
    Today I cannot use my computer. I get the following message.
    Unapproved Caller
    Security Agent may only be invoked by Apple Software

    I have booted in all possible modes, I have repaired disk permissions, I have verified the internal hard disk. All the above multiple times. I have unplugged for 15 seconds, plugged for 5 and booted. I a have tried all that I know and a few things I did not know.
    All to no avail, the problem remains.
    HELP!

    Thanks
     
  2. reefer110 macrumors member

    Joined:
    Oct 12, 2011
    Location:
    UK
    #2
    Exactly the same happened to me last week, a trip to the Apple store and a new flat hard drive cable sorted the problem.
     
  3. luisfelipetrigo thread starter macrumors newbie

    Joined:
    Sep 13, 2011
    #3
    Not an option for me.
    I live in Cancun.
    Closest Apple Retail Store is in Miami. :)
    Thanks anyway.
     
  4. luisfelipetrigo thread starter macrumors newbie

    Joined:
    Sep 13, 2011
    #4
    Security Agent may only be invoked by Apple Software

    I have a progress report (with no much progress).
    After some more frustration in front of my iMac trying things I was able to connect to Internet and run a new Mavericks install. This was done by booting with Cmd-R.

    The process took most of the night and this morning it was finished.
    But I still have Finder freezing after a while; pages, numbers and such freezing before opening.

    So, frustration keeps growing and I keep trying... but I am lost.

    Thanks for your help.
     
  5. swordfish5736 macrumors 68000

    swordfish5736

    Joined:
    Jun 29, 2007
    Location:
    Cesspool
    #5
    The hard drive and/or cable could be failing. I would make sure any important data is backed up and either find an authorized repair center near you or see if you feel comfortable opening up your iMac, instructions here.
     
  6. abstert macrumors newbie

    Joined:
    Jun 10, 2008
    Location:
    Santa Clara, CA
    #6
    Fix for Unapproved Caller

    Hello,

    The problem you are experiencing is a bad clean up job after an OS upgrade. When upgrading from 10.9 to either 10.9.1 or 10.9.2, the installer is supposed to delete/remove files from the "/var/folders/" directory. This fails which causes faulty requests for elevated privileges in different areas of the OS.

    To fix this issue, simply remove the caches in the "/var/folders" directory by running the command below:
    Code:
    sudo rm -rf /var/folders/*
    Let me know if this worked out for you.

    Thanks,
    Abraham
     

Share This Page